Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 11 van 11

Onderwerp: Als functie 2 voorwaarden

  1. #1
    Vraag is niet opgelost

    Als functie 2 voorwaarden

    Hoi Hoi!

    Ik wil een telefoonfactuur als volgt specificeren:
    voorwaarde 1 = "bellen naar mobiel"; "internationaal"
    voorwaarde 2 = bellen met nummer 0000000000; 1111111111

    als het aan beiden voorwaarden voldoet (stel internationaal en 0000000000) dan moet hij de kosten hiervoor op tellen.

    Ik heb verschillende dingen geprobeerd ( Als(EN en Als(Als ) maar kom er echt niet uit

    Alvast bedankt!

  2. #2
    Giga Honourable Senior Member
    Geregistreerd
    6 april 2006
    Locatie
    Mechelen
    Afstand tot server
    ±190 km
    Hang eens een voorbeeldbestandje bij met fictieve gegevens, dan kent men hier de structuur van de data.

  3. #3

    gegevens

    Hoi,

    Ik hoop dat je onderstaande bedoeld:

    A B C
    nummer kenmerk kosten
    1 055-1234567 mobiel 0,25
    2 055-1234567 internationaal 1,45
    3 055-1234567 mobiel 0,08
    3 055-9876543 mobiel 0,73
    5 055-9876543 internationaal 13,12

    Naast deze kolommen bestaan er nog meer kolommen (o.a. gebelde nummer, gespreksduur) Volgens mij niet relevant voor mijn vraag.
    Totaal bestaat het bestand uit 5 verschillende nummers en 6 verschillende kenmerken.
    Het totaal van de 5 nummers is goed voor maandelijks zo' n 5000 rijen aan (gespreks)data.
    De data is in het bestand gesorteerd op nummer.

    De volgende twee overzichten zijn gewenst:

    -totale kosten mobiel bellen met nummer 055-1234567: 0.33 (C1 +C3)
    -totale kosten internationaal: 14,57 (C2 + C5)

    Met name gaat het mij om welke formule ik moet gebruiken om het eerste overzicht te verkrijgen.

  4. #4
    Giga Honourable Senior Member
    Geregistreerd
    6 april 2006
    Locatie
    Mechelen
    Afstand tot server
    ±190 km
    =SOMPRODUCT((A1:A5="055-1234567")*(B1:B5="mobiel")*C1:C5)

    en

    =SOM.ALS(B1:B5;"internationaal";C1:C5)

    Wigi

  5. #5
    Bedankt voor de snelle reacties!

    Helaas kom ik er nog niet uit.
    Misschien is het handig dat ik het orginele bestand op de mail zet?
    Het lukt mij namelijk niet om een exe bestand bij te voegen.
    Hopelijk maakt dit het duidelijker.

    Alvast bedankt

  6. #6
    Gewoon zippen of rarren is voldoende. En het hoeft niet het hele bestand te zijn maar een deel. Al is het complete bestand het makkelijkst natuurlijk

  7. #7
    hierbij dan het bestand.
    het is een gedeelte..
    bedankt!
    Attached Files Attached Files

  8. #8
    Mega Senior bandito bob's avatar
    Geregistreerd
    26 juni 2007
    Locatie
    Zoetermeer
    Afstand tot server
    ±147 km
    Quote Origineel gepost door stehennepe Bekijk Bericht
    hierbij dan het bestand.
    het is een gedeelte..
    bedankt!

    =SOMPRODUCT((B2:B3280=B2)*(A2:A3280=A2)*G2:G3280)

    werkt wel.

    enige uitleg: Je wou de tekst van kolom C optellen (wat niet kan), hier heb ik G van gemaakt. En ik heb de range gezet vanaf regel 2.
    Laatst aangepast door bandito bob : 27 november 2007 om 15:24
    groeten Paul.

  9. #9
    Quote Origineel gepost door bandito bob Bekijk Bericht
    =SOMPRODUCT((B2:B3280=B2)*(A2:A3280=A2)*G2:G3280)

    werkt wel.

    enige uitleg: Je wou de tekst van kolom C optellen (wat niet kan), hier heb ik G van gemaakt. En ik heb de range gezet vanaf regel 2.
    Was me net op voor. Maar hier kun je wel je sheet mee afmaken

  10. #10
    Haha ok dan!
    Dank jullie wel.

  11. #11
    Giga Honourable Senior Member
    Geregistreerd
    6 april 2006
    Locatie
    Mechelen
    Afstand tot server
    ±190 km
    Zet de vraag nog op opgelost aub.

  • Dit topic is automatisch gesloten omdat er sinds vier maanden niet meer op gereageerd is.

    Indien gewenst kan de topicstarter een verzoek tot heropening indienen.
  • Berichtenregels

    • U mag geen nieuwe vragen starten.
    • U mag niet reageren op berichten.
    • U mag geen bijlagen versturen.
    • U mag uw berichten niet bewerken.
    •  
    Helpmij.nl
    Helpmij.nl

    Helpmij.nl en business

    Partners
    Sponsoren
    Linkpartners
    Aanbiedingen