Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 5 van 5

Onderwerp: Vert.zoeken, met Links in de zoekwaarde

  1. #1
    Senior Member
    Geregistreerd
    26 juni 2009
    Locatie
    Hasselt Vlaanderen
    Vraag is opgelost

    Vert.zoeken, met Links in de zoekwaarde

    In onderstaande formule zit blijkbaar een fout.
    Code:
    =ALS(B3="";"";VERT.ZOEKEN(LINKS(B3;1);Blad1!A2:C$100;3;0))
    De zoekwaarde: LINKS(B3;1) vindt op Blad1 in Kolom A niet die waarde.
    De zoekwaarde is opgemaakt als Tekst, en de zoekkolom is ook opgemaakt als Tekst.
    Weet iemand de oplossing?
    Attached Files Attached Files

  2. #2
    Mega Honourable Senior Member
    Geregistreerd
    19 mei 2007
    PHP Code:
    1
    2
    3
    
    =ALS($B3="";"";INDEX(Blad1!$C$2:$C$100;VERGELIJKEN(LINKS($B3;1)*1;Blad1!$A$2:$A$100;0)))
    en
            =ALS($B3="";"";INDEX(Blad1!$C$2:$C$100;VERGELIJKEN(RECHTS($B3;1)*1;Blad1!$A$2:$A$100;0)))

    Ik weet wel niet precies wat je zoekt.
    Laatst aangepast door Cobbe : 10 januari 2017 om 17:41
    Mvgr. & succes, Cobbe

    Heb je een oplossing voor je probleem,
    vergeet dan niet de vraag als opgelost te merken.
    En denk er aan: Zorgen moet je doen, niet maken.

  3. #3
    Senior Member
    Geregistreerd
    26 juni 2009
    Locatie
    Hasselt Vlaanderen
    Super Cobbe, dat was het!
    Weeral help je mij verder. Bedankt.

  4. #4
    Mega Honourable Senior Member
    Geregistreerd
    2 maart 2013
    Het kan natuurlijk ook met vertikaal zoeken.

    Code:
    =ALS(B3="";"";VERT.ZOEKEN(--LINKS(B3;1);Blad1!A2:C$100;3;0))

  5. #5
    Senior Member
    Geregistreerd
    26 juni 2009
    Locatie
    Hasselt Vlaanderen
    Fijn dat je helpt VenA,
    Het was dan ook een Vert.Zoeken- formule die ik gebruikte.
    Het was voldoende om de zoekwaarde * 1 te doen, zoals Cobbe voorstelde.
    Ik ga nu ook jouw formule uittesten, hoewel de betekenis van die [--]-toevoeging mij ontgaat.

    ps. Ik heb ondertussen getest, werkt ook perfect. Bedankt!!!!
    Laatst aangepast door wieter : 10 januari 2017 om 18:19

  6. Dit topic is automatisch gesloten omdat er sinds vier maanden niet meer op gereageerd is.

    Indien gewenst kan de topicstarter een verzoek tot heropening indienen.

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren
Aanbiedingen