Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 7 van 7

Onderwerp: vert.zoeken

  1. #1
    Senior Member cor.de.kruijf's avatar
    Geregistreerd
    5 maart 2001
    Locatie
    Cothen
    Afstand tot server
    ±66 km
    Vraag is opgelost

    vert.zoeken

    goedemiddag,

    kan iemand mij alsjeblieft helpen?
    in bijgevoegd voorbeeld probeer ik een deel van de tekst (bv paypall) in kolom B van Mrt 3 laten resulteren in "card" in kolom F.
    in B1 komt ideal voor wat als resultaat in F1 "ing" zou moeten gevenFinance2017.xls
    deze gegevens moeten komen uit de lijst in deb_cred

    Als alleen paypall in bv B7 staat werkt het maar de bedoeling is dat het met B6 ook lukt.
    ik heb me al suf gezocht in allerlei online voorbeelden maar het lukt me niet

    zie voorbeeld sheet

    mvg Cor
    Wanneer je veel achter je computer zit, zul je nooit weten wat er op je scherm staat.

  2. #2
    Mega Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Mogelijke oplossing:
    Code:
    F1: =ALS.FOUT(INDEX(deb_cred!B:B;MIN(ALS(ISGETAL(VIND.SPEC(deb_cred!$A$2:$A$200;'Mrt 3'!B1));RIJ(deb_cred!$A$2:$A$200);10^99)));"")
    Let op: matrixformule, d.w.z. afsluiten met Control+Shift+Enter na invoeren.
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  3. #3
    Giga Senior
    Verenigingslid
    robdgr's avatar
    Geregistreerd
    8 september 2001
    Locatie
    Voorthuizen
    Afstand tot server
    ±36 km
    Een keuze inbouwen:
    Code:
    =ALS.FOUT(VERT.ZOEKEN(TEKST.SAMENVOEGEN("*";B7;"*");deb_cred!$2:$57;2;0);VERT.ZOEKEN(TEKST.SAMENVOEGEN("*";B7);deb_cred!$2:$57;2;0))
    Groet,

    Rob

    PS: Kijk ook eens op mijn site voor natuur-, maar ook andere foto's en diverse Excel-bestanden.

  4. #4
    Mega Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Rob, dit gaat niet goed denk ik. Als je zoekt op "*aquastore zwarte kit ideal*" op het tweede tabblad zul je niets vinden. Het gaat om het woordje "ideal" dat gevonden moet worden op het tweede tabblad, met daarbij behorend de gevonden waarde "ing".

    Ik heb het dus omgedraaid: er wordt gekeken of de woorden uit de tabel op het tweede tabblad voorkomen op de regel in het eerste tabblad.
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  5. #5
    Senior Member cor.de.kruijf's avatar
    Geregistreerd
    5 maart 2001
    Locatie
    Cothen
    Afstand tot server
    ±66 km
    @AlexCEL
    De matrixformule lijkt te werken behalve in rij 6
    als ik daar "Bewado" weglaat doet ie het wel, ik kan daar mee leven maar begrijpen waarom doe ik niet

    in ieder geval al heel hartelijk bedankt voor deze oplossing, ook voor die van Rob uiteraard

    met vriendelijke groet, Cor
    Wanneer je veel achter je computer zit, zul je nooit weten wat er op je scherm staat.

  6. #6
    Mega Honourable Senior Member
    Geregistreerd
    2 maart 2013
    je hebt in de tab 'deb_cred' in A2 Ad staan. En laat dat nu in 'Bewado' zitten

    Met een kleine aanpassing werkt het wel.
    Code:
    =ALS.FOUT(INDEX(deb_cred!B:B;MIN(ALS(ISGETAL(VIND.SPEC(deb_cred!$A$3:$A$200;'Mrt 3'!B1));RIJ(deb_cred!$A$3:$A$200);10^99)));"")
    Je kan een paard naar het water leiden, maar je kan het niet dwingen te drinken.

  7. #7
    Senior Member cor.de.kruijf's avatar
    Geregistreerd
    5 maart 2001
    Locatie
    Cothen
    Afstand tot server
    ±66 km
    Ahhhh....... stom van mij

    nogmaals heel hartelijk dank, werkt perfect nu
    Wanneer je veel achter je computer zit, zul je nooit weten wat er op je scherm staat.

  8. Dit topic is automatisch gesloten omdat er sinds vier maanden niet meer op gereageerd is.

    Indien gewenst kan de topicstarter een verzoek tot heropening indienen.

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren
Aanbiedingen