Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 10 van 10

Onderwerp: Waarden tellen met criterium...

  1. #1
    Vraag is opgelost

    Waarden tellen met criterium...

    Hi all,

    Ik zou graag van het bestandje in de bijlage weten hoeveel orders elke leverancier geplaatst heeft.
    Dus het aantal unieke ordernummers per leverancier bij elkaar optellen...

    Anyone? Thanks!

    Martijn

    Tellen.xlsx

  2. #2
    In cel C2: =SOM(--(INTERVAL(ALS($B$2:$B$31=B2;$A$2:$A$31);$A$2:$A$31)>0))
    LET OP: Matrixformule dus afsluiten/ingeven met CTRL+SHIFT+ENTER!!!
    Doortrekken naar beneden
    Laatst aangepast door arrie23 : 21 april 2017 om 15:15

  3. #3
    Hey Arrie,

    Bedankt voor je rappe respons!

    Dit werkt inderdaad in het voorbeeld-sheetje, maar zodra ik het in mijn werksheet wil toepassen, krijg ik overal 0.

    Dit is de formule geworden:
    {=SOM(--(INTERVAL(ALS([SupplierID]=[@SupplierID];[OrderID]);[OrderID])>0))}

    Moet dat zo kunnen, met die namen?

    Martijn

  4. #4
    Mega Honourable Senior Member
    Geregistreerd
    2 maart 2013
    Bij mij ziet de formule er zo uit als ik uitga van het voorbeeldbestand.

    Code:
    =SOM(--(INTERVAL(ALS([LeverancierID]=Tabel1[[#Deze rij];[LeverancierID]];[OrderID]);[OrderID])>0))
    Je kan een paard naar het water leiden, maar je kan het niet dwingen te drinken.

  5. #5
    Ik snap niet waarom hij het bij mij nog steeds niet doet (Excel 2010)

    Wil je het eens in deze bijlage proberen?

    Report.xlsx

    Bedankt voor je hulp!

  6. #6
    Mega Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Haal al die apostrofs eens weg uit de kolom B (en andere relevante kolommen).

    Je hebt hiermee een GETAL in TEKST geconverteerd, daarmee werkt de formule hierboven niet meer.
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  7. #7
    Mega Honourable Senior Member
    Geregistreerd
    2 maart 2013
    Er staat nergens een formule. Dus zeer waarschijnlijk dat het daarom niet werkt. Ook staat er tekst in de kolommen ipv getallen en dat maakt het ook weer anders. En de kolomnamen kloppen ook niet en dan gaat er natuurlijk nooit wat werken. Voorbeeldjes dienen representatief te zijn!
    Laatst aangepast door VenA : 21 april 2017 om 19:08
    Je kan een paard naar het water leiden, maar je kan het niet dwingen te drinken.

  8. #8
    Mega Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Hierbij de formule in het voorbeeld.

    Diverse kolommen hebben aangepaste opmaak i.v.m. de voorloopnullen.
    Attached Files Attached Files
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  9. #9
    Bedankt voor jullie reacties!

    Kan de OrderID-kolom nog wel een getal zijn als ik de voorloopnullen wil behouden?
    De SupplierID kan inderdaad een getal worden, dat pas ik aan!

    Deze gegevens worden met een Excel-plugin uit ons systeem gehaald, zo komen met een ' binnen...

  10. #10
    Guys het is gelukt, dank voor jullie hulp!

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren
Aanbiedingen