Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 5 van 5

Onderwerp: Index formule voor rijen met meerdere voorwaarden

  1. #1
    Vraag is opgelost

    Index formule voor rijen met meerdere voorwaarden

    Sorry, maar ik kom er niet uit

    Ik heb een bestand met 2 sheets. de ene is het blad waar de uitkomsten moeten komen de andere is het blad waar de data staat

    nu wil ik graag dat alleen de rijen getoond worden uit t datablad die voldoen aan de naam en het weeknummer

    ik gebruik nu deze formule:
    Code:
    IFERROR(INDEX('Data'!B$2:B$1000,MATCH(ROWS($1:1),'Data'!$R$2:$R$1000,0)),"")
    maar ik weet niet hoe ik m moet aanpassen naar 2 voorwaarden

    hoop dat iemand kan helpen

    voorbeeld index.xlsx

  2. #2
    Mega Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Zo:
    Code:
    [NL]B5: =ALS.FOUT(INDEX(Data!A:A;KLEINSTE(ALS(Data!$B$2:$B$1000=$C$2;1;9^9)*ALS(Data!$A$2:$A$1000=$E$2;1;9^9)*RIJ($2:$1000);RIJ()-4));"")
    
    [EN]B5: =IFERROR(INDEX(Data!A:A,SMALL(IF(Data!$B$2:$B$1000=$C$2,1,9^9)*IF(Data!$A$2:$A$1000=$E$2,1,9^9)*ROW($2:$1000),ROW()-4)),"")
    Zoals wellicht bekend zijn het matrixfuncties, dus afsluiten met Control+Shift+Enter alvorens doorvoeren naar rechts en onder.
    Laatst aangepast door AlexCEL : 13 oktober 2017 om 13:21
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  3. #3
    helemaal goed hartelijk dank

    ik zit nog met een klein probleempje, hij selecteert nu maar 2 rijen terwijl er 3 zijn van naam A. ik weet niet waar dat in zit??

  4. #4
    Mega Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Naam A in combinatie met week 42 komt maar 2x voor.

    Dit resultaat wilde je toch...?
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  5. #5
    Schaam, Schaam , Schaam

    zou zweren dat ik m 3x had ingevuld. mijn fout hartelijk dank

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren
Aanbiedingen