Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 4 van 4

Onderwerp: vreemd gedrag excelsheel met vertikaal zoeken

  1. #1
    Junior Member
    Geregistreerd
    2 maart 2007
    Vraag is niet opgelost

    vreemd gedrag excelsheel met vertikaal zoeken

    Ik heb een excelsheet gemaakt met daarin een paar kolommen.
    In kolom D staan getallen onder elkaar van 100 t/m 1600
    In kolom E staan waardes van 2 t/m 32. Echter zijn deze variabel, dus in de cellen E5 t/m E20 zitten formules in.
    In kolom H5 staat een vertikaal.zoeken formule ( =VERT.ZOEKEN(J5;D4:E20;E5;1)/2 ) Het zoekgetal hiervan is cel J5Controlegetallen.xlsx
    In kolom I5 t/m I20 kunnen waardes toegevoegd worden.Standaard staan deze op 0.
    In kolom J5 staat het richtgetal in een lijst van getallen uit kolom D.
    In kolom L staan de nominale waardes.

    Als alles in de uitgangspositie staat werk het goed. Als ik het richt getal instel dan veranderd de gezochte waarde keurig mee.
    Alleen als ik in cel I5 of L5 de waarde aanpas loopt het fout.
    Als ik waardes verander in andere cellen dan is er niets aan de hand.

    Ik heb het voorbeeldbestand bijgevoegd..
    Iemand een idee hoe dit komt...

    Alvast bedankt voor het mee denken.

    Burnitall1

  2. #2
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Code:
    =VERT.ZOEKEN(J5;D4:E20;E5;1)
    Het gaat fout omdat je via E5 verwijst naar een kolom die niet bestaat. Zet hier eens een 2 neer...

    Alternatief voor VERT.ZOEKEN-functie:
    Code:
    =INDEX(E5:E20;VERGELIJKEN(J5;D5:D20;1))
    Laatst aangepast door AlexCEL : 13 maart 2018 om 21:03
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  3. #3
    Giga Senior Ginger's avatar
    Geregistreerd
    29 december 2006
    Locatie
    Delft
    Afstand tot server
    ±162 km
    =VLOOKUP(J5;$D$4:$E$20;2;1)/2

    En het vastzetten van je zoekbereik gaat je ook helpen...
    ____________________________
    GINGER AlsoKnownAs REDHEAD
    + + + + + + + + + + + + + + + + + + + + + + + + + +
    Test een nieuwe VBA-code altijd éérst uit op een
    kopie van het bestand ipv direct in het orgineel...!

    + + + + + + + + + + + + + + + + + + + + + + + + + +

  4. #4
    Junior Member
    Geregistreerd
    2 maart 2007
    Top .
    Dank je wel..

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren
Aanbiedingen