Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 8 van 8

Onderwerp: Lijst genereren zonder dubbele data

  1. #1
    Junior Member
    Geregistreerd
    5 oktober 2011
    Vraag is niet opgelost

    Lijst genereren zonder dubbele data

    Hallo,

    ik heb een excelbestand met 2 tabbladen.
    In tabblad 1 staat in kolom A een lijst met producten, hoe lang deze lijst is is altijd anders.
    Nu wil ik graag dat op tabblad 2 diezelfde lijst wordt gegenereerd maar dat alle duplicaten er uit worden gefilter.

    Dit wil ik automatiseren met een formule, ik wil green gebruik maken van het filter systeem van Excel.

    Heb op internet al veel gezocht maar krijg hetgeen ik zoek niet gevonden. Kan iemand mij op weg helpen?

  2. #2
    Senior Member
    Geregistreerd
    9 januari 2018
    Gegevens-->Duplicaten verwijderen

  3. #3
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Deze voor blad2, cel A2, sorteert unieke waarden uit bereik A2:A1000 op blad1.
    Code:
    =ALS.FOUT(ZOEKEN(2;1/((AANTAL.ALS($A$1:A1;Blad1!$A$2:$A$1000)=0)*(Blad1!$A$2:$A$1000<>""));Blad1!$A$2:$A$1000);"")
    of
    =ALS.FOUT(INDEX(Blad1!$A$2:$A$1000;VERGELIJKEN(0;ALS(ISLEEG(Blad1!$A$2:$A$1000);1;AANTAL.ALS($A$1:A1;Blad1!$A$2:$A$1000));0));"")
    Let op: matrixfuncties, d.w.z. afsluiten met Control+Shift+Enter alvorens doortrekken naar onder.

    Meer assistentie: plaats een voorbeeldbestand (Excel).
    Laatst aangepast door AlexCEL : 12 juli 2018 om 10:39
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  4. #4
    Mega Honourable Senior Member
    Geregistreerd
    2 maart 2013
    Waarom geen filtersysteem? Het geavanceerde filter is hiervoor gemaakt.
    Je kan een paard naar het water leiden, maar je kan het niet dwingen te drinken.

  5. #5
    Junior Member
    Geregistreerd
    5 oktober 2011
    Derving Tool Brood.xlsxDerving Tool Brood.xlsx

    Dit is het voorbeeld.

    Uitvoer bezit de data in kolom D vanaf rij 7. In tab "conclusies" op A1 staat de code die je gaf, echter krijg ik als resultaat "0". Misschien zie je wat ik fout doe?


    Edit: formule in het voorbeeld had ik niet helemaal goed aangepast.
    Echter formule is nu dit:

    Code:
    =ALS.FOUT(ZOEKEN(2;1/((AANTAL.ALS($A$1:A1;Uitvoer!$D$7:$D$15000)=0)*(Uitvoer!$D$7:$D$15000<>""));Uitvoer!$D$7:$D$15000);"")
    Echter nog steeds output "0"


    De reden dat ik geen filter wil gebruiken is omdat het geautomatiseerd moet gaan. Van de data wordt straks een dropdownlist gemaakt.
    Laatst aangepast door icecube87 : 12 juli 2018 om 21:52

  6. #6
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Code:
    =ALS.FOUT(ZOEKEN(2;1/((AANTAL.ALS($B$1:B1;Uitvoer!$D$7:$D$15000)=0)*(Uitvoer!$D$7:$D$15000<>""));Uitvoer!$D$7:$D$15000);"")
    of
    =ALS.FOUT(INDEX(Uitvoer!$D$7:$D$15000;VERGELIJKEN(0;ALS(ISLEEG(Uitvoer!$D$7:$D$15000);1;AANTAL.ALS($B$1:B1;Uitvoer!$D$7:$D$15000));0));"")
    Een van deze functies moet in cel B2 staan.

    De tweede functie staat ook niet goed overgenomen in je voorbeeld hierboven.

    En als je post #3 nog eens goed leest dan zie je staan:
    Let op: matrixfuncties, d.w.z. afsluiten met Control+Shift+Enter alvorens doortrekken naar onder.


    Hierna krijg je de lijst. En die begint met een 0 of daarin komt een 0 voor, omdat dit een unieke waarde is die in kolom D op tabblad Uitvoer voorkomt.
    Laatst aangepast door AlexCEL : 12 juli 2018 om 22:59
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  7. #7
    Mega Honourable Senior Member
    Geregistreerd
    2 maart 2013
    Mij lijkt een filter aanzienlijk sneller dan een matrixformule over 15k rijen die elke keer herberekend wordt.

    In de module van het blad 'Conclusies'
    Code:
    Private Sub Worksheet_Activate()
      Sheets("Uitvoer").Cells(6, 1).CurrentRegion.Columns(4).AdvancedFilter 2, , Cells(1), True
    End Sub
    @AlexCEL, U hoeft niet zo te schreeuwen
    Je kan een paard naar het water leiden, maar je kan het niet dwingen te drinken.

  8. #8
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    @AlexCEL, U hoeft niet zo te schreeuwen
    Soms lucht het even op

    Maar on-topic: hoop inderdaad dat TS een stevige PC heeft...
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren