Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Pagina 1 van 2 1 2 LaatsteLaatste
Weergeven resultaten 1 tot 20 van 25

Onderwerp: =als formule verkorten en makkelijker maken

  1. #1
    Junior Member
    Geregistreerd
    11 januari 2019
    Vraag is niet opgelost

    =als formule verkorten en makkelijker maken

    hallo allemaal,

    ik ben vandaag begonnen aan een excel sheet die mij het makkelijker moet maken op de juiste draaival beslag te bestellen.

    nu heb ik de grove opzet al voor elkaar met behulp van dit forum, maar ik ben er nog niet helemaal.

    ik heb de volgende formule nodig op mijn excel sheet te laten werken.

    Code:
    =ALS(C18=0;" ";ALS(EN(C18>=0,01;C18<=100);(L$15);ALS(EN(C18>=100,1;C18<=200);(L$16))))
    nu heb ik echter nog maar 2 celrijen te pakken ( L16 & L15 ), en terwijl ik er misschien wel 40 nodig heb.

    ik wil deze formule dus makkelijker maken.

    in D15 staat de formule.

    kunnen jullie mij hier advies over geven en me misschien zelfs opweg helpen?

    ik zal ook een voorbeeld toevoegen van wat ik al gemaakt heb.

    bij voorbaat dank!
    Bijgevoegde bestanden Bijgevoegde bestanden
    Laatst aangepast door snb : 11 januari 2019 om 09:26

  2. #2
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Zie bijlage voor een mogelijke oplossing.
    Bijgevoegde bestanden Bijgevoegde bestanden
    Laatst aangepast door AlexCEL : 11 januari 2019 om 08:35
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  3. #3
    Vergelijkbare oplossing als AlexCel maar met vert.zoeken formule ipv index en match (en zonder tabelfunctionaliteit)

    vert.zoeken en index met match formule zijn zegmaar de geavancerde broertjes van een als-formule. Zodra je meer dan ca 3 criteria hebt wordt het al snel efficienter om een opzoek tabelletje te maken. Heeft in veel gevallen ook als voordeel als maatvoeringen veranderen dat je dan alleen 1 tabelletje hoeft aan te passen in plaats van door je 4 meter lange als formule te gaan en alle waarden aan te passen.
    Bijgevoegde bestanden Bijgevoegde bestanden

  4. #4
    Junior Member
    Geregistreerd
    11 januari 2019

    uitleg

    hoi alexcl,

    heb net even snel gekeken, en dit is zeer waarschijnlijk wat ik zoek.

    ik ga me vanavond even goed verdiepen in wat je voor me gemaakt hebt!

    en ik wil je alvast bedanken voor je hulp!

    ik weet niet of het te veel gevraagd, maar kun je mij uitleggen hoe deze formule nu werkt zodat ik begrijp wat hij doet?

    Code:
    =ALS($C15<>"";INDEX(Tabel1[klink];ALS.FOUT(VERGELIJKEN($C15;$K$15:$K$59)+(OPZOEKEN($C15;$K$15:$K$59)<>$C15);1));"")
    wat maakt nu de vergelijking met waar hij moet zoeken, of welke combinatie doet dat?

    ik vermoed zelf de
    Code:
    =ALS($C15<>""
    maar wat doet dan de
    Code:
    INDEX(Tabel1[klink]
    en de
    Code:
    ALS.FOUT(VERGELIJKEN(
    alvast hartelijk bedankt!

  5. #5
    Moderator
    Verenigingslid

    Geregistreerd
    12 juni 2008
    Gebruik in D15:
    PHP Code:
    1
    
    =IF(C15="";"";"GR " & INT(C15/100)+1)
    Laatst aangepast door snb : 11 januari 2019 om 09:37
    VBA voor smarties
    VBA is een taal die je moet leren met een grammatica- en een woordenboek.

    http://www.helpmij.nl/forum/announcement.php?f=5
    Plaats svp geen bestanden op andere sites; nadat het bestand daar verwijderd is wordt een forumdraad onbegrijpelijk voor anderen.

  6. #6
    Senior Member
    Geregistreerd
    23 mei 2013
    of ook deze

    Code:
    =ALS(C15<>"";VERT.ZOEKEN(AFRONDEN.BOVEN(C15;100);$K$15:$AD$22;2;0);"")
    Bijgevoegde bestanden Bijgevoegde bestanden
    Laatst aangepast door emields : 11 januari 2019 om 10:02

  7. #7
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Ik heb bewust niet gekozen voor afronden, omdat er waarschijnlijk ook wel stapjes van 25 of 50 in zitten. Nu zoekt hij altijd de gelijke of eerstvolgende grotere waarde.

    Het VERGELIJKEN deel vergelijkt (duh...) de op te zoeken waarde met de lijst in kolom K. Deze retourneert de eerst gevonden waarde die kleiner of gelijk is aan de zoekwaarde.
    Je wilt echter het eerste getal dat GROTER of gelijk is aan de zoekwaarde. Daar zorgt het ZOEKEN deel voor. Die hoogt het rij-nummer met 1 op indien er geen overeenkomst is.
    De INDEX zoekt het gevonden rijnummer op de eerste kolom van de Tabel1. Die heb je "klink" genoemd, oftewel: Tabel1[klink].
    De ALS.FOUT zit erin voor waarden kleiner dan 100, die anders in een foutmelding resulteren. Alternatief zou zijn om waarde 0 op te nemen in de tabel.

    Deze kan ook (zonder ALS.FOUT):
    Code:
    =ALS($C15<>"";INDEX(Tabel1[klink];VERGELIJKEN(MAX(100;$C15);$K$15:$K$59)+(ZOEKEN(MAX(100;$C15);$K$15:$K$59)<>$C15));"")
    Laatst aangepast door AlexCEL : 11 januari 2019 om 12:09
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  8. #8
    Junior Member
    Geregistreerd
    11 januari 2019

    volgende fase

    hallo allemaal!

    fijn dat jullie allemaal mee denken!.

    ik heb even het volgende wat duidelijker uitgewerkt.

    kijk er even naar en laat me weten wat jullie vinden/ denken.

    ik heb ook niet alles duidelijk verteld en dit schept wat verwarring.

    [ATTACH]333689[/ATTACH][ATTACH]333690[/ATTACH]

    1 bijlage is van mijn groothandel waar ik normaal mee werk.
    deze lijst is ook online te vinden dus ik denk dat dit geen probleem is.
    Bijgevoegde bestanden Bijgevoegde bestanden
    Laatst aangepast door snb : 11 januari 2019 om 14:21

  9. #9
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Opzoeken gaat goed toch?
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  10. #10
    Junior Member
    Geregistreerd
    11 januari 2019
    Hoi alexcl,

    Ja het werkt super!
    Het enigste wat ik nog kan bedenken is als de waarde onder te toegestane waarde komt.

    Dus is het in de praktijk niet te maken maar geeft hij wel een waarde aan.

    Is dat ook nog te maken dat hij dat bv aangeeft dat de maatvoering te klein is?

  11. #11
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Zo wellicht? In je eerste voorbeeld:
    Code:
    =ALS($C15<>"";ALS.FOUT(INDEX(Tabel1[klink];VERGELIJKEN($C15;$K$15:$K$59)+(ZOEKEN($C15;$K$15:$K$59)<>$C15));"maatvoering te klein");"")
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  12. #12
    Junior Member
    Geregistreerd
    11 januari 2019
    hoi alexcel,

    ik ben dankbaar voor de hulp!
    ook roeljongman en snb en emields!

    ik heb het even uitgeprobeerd maar hij geeft de melding als ik onder de maximale maatvoering kom.
    het laatste voorbeeld wat ik mee gestuurd heb staat nu ook een kollom met een minimale maatvoering.


    de melding is pas van toepassing als de laagte waarde van de kolom minimaal bereikt.
    dat is per kolom dus maar 1 laagste waarde.
    is deze handmatig in te voeren in de formule.

    bv bij, I.S. ESPAHNOLET ( 5 ) is de laagste waarde 360.

    https://www.helpmij.nl/forum/attachm...0&d=1547209417

    alles daar onder bestaat niet, dus dit hoef ik maar 1 keer te vermelden in de code.

    of heb ik het dan mis?

    b.v.d. !
    Laatst aangepast door timmerman01 : 11 januari 2019 om 15:05

  13. #13
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    In jouw sheet kan het e.e.a. nog wel wat versimpeld worden:
    Code:
    D4: =ALS($C15<>"";ALS($C15<H$15;"maatvoering te klein!";INDEX(Tabel4[I.S. ESPAHNOLET ( 5 )];VERGELIJKEN($C15;$H$15:$H$30)));"")
    Moet er ook nog een melding komen voor te grote maatvoering?
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  14. #14
    Moderator
    Verenigingslid

    Geregistreerd
    12 juni 2008
    @timmerman

    Wil je je svp aanleren bij het plaatsen van een bijlage de knop 'Gereed' in het 'Beheer bijlagen' subscherm aan te klikken in plaats van de knop 'voer in' ?
    Bijgevoegde kleine afbeeldingen Bijgevoegde kleine afbeeldingen Klik op afbeelding voor grotere versie

Naam:  Bijlagen_toevoegen.PNG‎
Bekeken: 9
Grootte:  44,6 KB  
    VBA voor smarties
    VBA is een taal die je moet leren met een grammatica- en een woordenboek.

    http://www.helpmij.nl/forum/announcement.php?f=5
    Plaats svp geen bestanden op andere sites; nadat het bestand daar verwijderd is wordt een forumdraad onbegrijpelijk voor anderen.

  15. #15
    Junior Member
    Geregistreerd
    11 januari 2019

    =als

    hallo snb, ik zal hier in de toekomst op letten.

    ik ben al een stuk verder gekomen!
    ik heb voor jullie nog een vraag, ik ben heb hier al weer een 3 uur aan gesleten en ik kom er niet uit.
    het is de bedoeling dat er in cel b15 L of R invullen, en dan moet er vervolgens in cell l15 het correcte artiekel nummer verschijnen.


    13-01-2019 fase 3.xlsx

    b.v.d.

  16. #16
    Senior Member
    Geregistreerd
    23 mei 2013
    en waar is dat artikelnummer te vinden?

  17. #17
    Moderator
    Verenigingslid

    Geregistreerd
    12 juni 2008
    @timmerman

    Kun je me uitleggen waarom je zegt erop te letten en het in hetzelfde bericht niet te doen ?
    VBA voor smarties
    VBA is een taal die je moet leren met een grammatica- en een woordenboek.

    http://www.helpmij.nl/forum/announcement.php?f=5
    Plaats svp geen bestanden op andere sites; nadat het bestand daar verwijderd is wordt een forumdraad onbegrijpelijk voor anderen.

  18. #18
    Junior Member
    Geregistreerd
    11 januari 2019
    Dat mag ik een tabel. Maar omdat er maar twee uitkomsten zijn dacht ik er zelf aan om het in de formule te verwerken,bijvoorbeeld L = 1234 en R = 5678
    Ik weet niet of dat de makkelijkste weg is.
    Als je onder hoeklager band vvm kijkt dan kunt u zien wat ik heb geprobeerd

  19. #19
    Junior Member
    Geregistreerd
    11 januari 2019
    Hallo snb,

    Ik heb de knop gereed gebruikt.

    Maar ik heb een paar pogingen gedaan omdat de browser niet mee wou werken.

    Wat gebeurt er als ik de gereed knop niet gebruik?

  20. #20
    Senior Member
    Geregistreerd
    23 mei 2013
    Probeer het eens met deze.

    Code:
    =ALS(B15="l";206357;ALS(B15="r";206358;""))

Pagina 1 van 2 1 2 LaatsteLaatste

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren