Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 15 van 15

Onderwerp: WordPress multisite blogs.dir probleem

  1. #1
    Senior Member damnsharp's avatar
    Geregistreerd
    6 januari 2012
    Locatie
    Oss
    Afstand tot server
    ±64 km
    Vraag is niet opgelost

    WordPress multisite blogs.dir probleem

    Goedemiddag,
    Bij een WP multisite (met een stuk of 20 subsites genaamd locatie01, locatie02, etc) uit 2015 klopt de directory structuur niet.
    Op zich werkt de site maar ik vind het vreemd wat er aan de hand is en zou willen weten waardoor het komt en aanpassen.

    Ik zie dat afbeeldingen van individuele subsites in \domeinnaam.nl\public_html\wp-content\blogs.dir\<siteid>\<jaartal> staan. Dat is een structuur die vóór de WP 3.5 werd gebruikt.
    De site is in 2015 gestart en toen was er WP 4 al. En daarna werden de afbeeldingen in wp-content\uploads\sites\<siteid>\<jaartal> gezet.

    En nog vreemder is dat er in de map boven public_html ook mapjes zijn met afbeeldigen en de naam van de individuele sites.
    Dus bijvoorbeeld:
    domeinnaam.nl\locatie01\public_html\wp-content\blogs.dir\36\files\

    Ik zou het graag zo krijgen dat het weer is zoals het hoort.
    \public_html\wp-content\uploads\sites\2
    \public_html\wp-content\uploads\sites\3
    etc

    Het zou kunnen dat het met de NS Cloner plug-in te maken heeft, die is gebruikt om van de hoofd-locatie site een kopie te maken naar locatie01, locatie02, etc.
    Ik heb ze gemaild maar verwacht er niet veel van.

    Kortom zou het via aanpassingen in de database en verplaatsen van bestanden te herstellen zijn?
    Laatst aangepast door damnsharp : 11 januari 2019 om 13:34

  2. #2
    Giga Senior femke98's avatar
    Geregistreerd
    16 december 2006
    Locatie
    Almere
    Afstand tot server
    ±76 km
    https://www.helpmij.nl/forum/forumdi.../623-WordPress

    hier moeten vragen over WP.

    verder zou een link fijn zijn, kunnen we ook eens spieken hoe of wat.
    Laatst aangepast door femke98 : 12 januari 2019 om 12:28

  3. #3
    Senior Member damnsharp's avatar
    Geregistreerd
    6 januari 2012
    Locatie
    Oss
    Afstand tot server
    ±64 km
    Ah ja, kan topic niet verplaatsen.

    Kan me voorstellen dat linkje fijn is, maar ik kan geen inlog geven want de multisite is afgeschermd.
    Zal een kopie van de multisite op een andere domeinnaam zetten en die tekstueel aanpassen.

    En vraag me tegelijk af of blogs.dir naar wp-content\uploads\sites te verplaatsen is.

  4. #4
    Giga Senior femke98's avatar
    Geregistreerd
    16 december 2006
    Locatie
    Almere
    Afstand tot server
    ±76 km
    Bij een WP multisite (met een stuk of 20 subsites genaamd locatie01, locatie02, etc) uit 2015 klopt de directory structuur niet.
    hoe bedoel je dit precies? En de sites werken maar werkt alles wel gewoon dan?

    De map waar de afbeeldingen worden geplaatst kan je aanpassen bij media.
    Omdat je voor en na 2014 de site hebt aangepast heb je daardoor die verschillen heb ik zo het idee.

    EN die pugin kan inderdaad de oorzaak zijn. Ik snap dat je alles weer wilt zoals je het zelf wilt, maar als alles werkt, en de site is niet langzaam hierdoor of wat dan ook, dan zou je het zo kunnen laten.

    Of je maakt hem helemaal overnieuw (op een test stukje server) en kopieert hem daarna weer op de originele.

    Ik heb zelf niet veel ervaring met multisites, ik hou er niet zo van omdat het voor mij persoonlijk dan zo onoverzichtelijk kan worden.

    Met link bedoelde ik de link van de website, niet van de inlog.

    ps. hier gekeken ? https://wordpress.org/support/plugin...er-site-copier En anders zet je hier je vraag neer.
    Laatst aangepast door femke98 : 13 januari 2019 om 12:30

  5. #5
    Senior Member damnsharp's avatar
    Geregistreerd
    6 januari 2012
    Locatie
    Oss
    Afstand tot server
    ±64 km
    Hoi femke98,
    Diverse afbeeldingen zijn niet meer zichtbaar (kruis) en wijzen naar verkeerde plek; toen viel me dat met die blogs.dir op.
    De site is in 2015 gemaakt en toen werd dat niet meer van blogs.dir bij WP gebruik gemaakt dus ik denk dat het ergens anders vandaan komt.
    Ik zal contact met de maker van nscloner opnemen.

    Bedankt voor het meedenken.

  6. #6
    Giga Senior femke98's avatar
    Geregistreerd
    16 december 2006
    Locatie
    Almere
    Afstand tot server
    ±76 km
    ZIjn het heel veel afbeeldingen? Anders kan je ze opnieuw plaatsen. Dus zoek het plaatje op in je mediamap en vind daar de link naar de afbeelding. Of in het bericht of op een pagina het kruis weghalen en opnieuw de afbeelding plaatsen dmv het zoeken van de afbeelding.

  7. #7
    Senior Member damnsharp's avatar
    Geregistreerd
    6 januari 2012
    Locatie
    Oss
    Afstand tot server
    ±64 km
    Hoi Femke,
    Ten eerste bedankt voor het meedenken!
    Het ligt jammer genoeg wat ingewikkelder.
    Komt ook omdat ik een plug-in gebruik die bij de hoofd site een pagina naar een "child" site kan dupliceren.
    Dat is jaren goed gegaan.

    Normaliter gaat het zo.
    1) Op domeinnaam.nl\testpagina plaats ik een afbeelding.
    2) Als ik klik op Publiceren wordt deze pagina geupdate en ook de child sites met de desbetreffende pagina.
    Dus bijvoorbeeld domeinnaam.nl\locatie01\testpagina en domeinnaam.nl\locatie02\testpagina en domeinnaam.nl\locatie03\testpagina.

    De afbeeldingen van de hoofdsite staan in letterlijk in /domains/domeinnaam.nl/public_html/wp-content/uploads/2019/01 bijvoorbeeld.
    De afbeeldingen van de child-sites staan in /domains/domeinnaam.nl/public_html/wp-content/blogs.dir/<ID van de child site>/files/.
    Maar, sinds een maand of zo komen ze te staan in /domains/domeinnaam.nl/locatie01/public_html/wp-content/blogs.dir/<ID van de child site>/files/2019/01/

    1) Waarom er in public_html een submap van de locatienaam komt met de media, is mij een raadsel.
    2) Als ik ze handmatig kopieer naar bijvoorbeeld /domains/domeinnaam.nl/public_html/wp-content/blogs.dir/47/files/2019/01/ zijn ze zichtbaar (want daar verwijst de link ook naar).

    Van de maker van de site clone software en de pagina-dupliceer software wacht ik nog op antwoord.

    Misschien moet ik handmatig wp-content/uploads/sites aan gaan maken, alles daarin zetten en verwijzingen in database goed zetten. Als dat het probleem oplost.

  8. #8
    Giga Senior femke98's avatar
    Geregistreerd
    16 december 2006
    Locatie
    Almere
    Afstand tot server
    ±76 km
    Je zou toch eerst eens moeten kijken in je dashboard bij media wat de map aangeeft waar de afbeeldingen worden gezet. Dus als er sites zijn die niet hetzelfde aangeven, kan je dit veranderen.
    Plus, de permalinken even nakijken of die ook wel hetzelfde zijn.

  9. #9
    Senior Member damnsharp's avatar
    Geregistreerd
    6 januari 2012
    Locatie
    Oss
    Afstand tot server
    ±64 km
    Ik ga het voor de zekerheid nakijken Femke, thanks!

  10. #10

  11. #11
    Senior Member damnsharp's avatar
    Geregistreerd
    6 januari 2012
    Locatie
    Oss
    Afstand tot server
    ±64 km
    Bedankt Femke.
    Die eerste link, ik vind dat ze kort door de bocht zijn... stoppen met multisite. Multisite werkt prima maar inderdaad wel ingewikkelder en gevoelig bij updates. Omdat WP er niet een "echte" multisite van maakt namelijk.
    Die tweede link zal ik doorlopen.
    Derde link staat te oude info in. Ze hebben het over htaccess van WP 3.5 en daarvoor.

    Zie ook dat bij een hostingbedrijf dat ze die rewrite rule gebruiken, en dat terwijl bij multisite de media tegenwoordig niet in blogs.dir opgeslagen wordt maar wp-content\uploads\sites.

  12. #12
    Giga Senior femke98's avatar
    Geregistreerd
    16 december 2006
    Locatie
    Almere
    Afstand tot server
    ±76 km
    multisite is naar mijn mening best overbodig geworden, te ingewikkeld en inderdaad gevoelig bij updates.
    Daarom denk ik dat er andere wegen zijn, maar goed dat is natuurlijk aan diegene die de website bouwt.

    Oude info of niet, wellicht is er nog iets te gebruiken, je weet maar nooit.
    Succes!

  13. #13
    Moderator bron's avatar
    Geregistreerd
    13 augustus 2013
    Locatie
    Voorburg
    Afstand tot server
    ±160 km
    @femke98 Om het voor Wordpress topic starters makkelijker te maken is de indeling van de subforums aangepast. Wordpress is nu makkelijk te vinden
    Voor bestaande- en nieuwe websites op smartphone, tablet en pc.

  14. #14
    Senior Member damnsharp's avatar
    Geregistreerd
    6 januari 2012
    Locatie
    Oss
    Afstand tot server
    ±64 km
    @bron goed bezig

  15. #15
    Giga Senior femke98's avatar
    Geregistreerd
    16 december 2006
    Locatie
    Almere
    Afstand tot server
    ±76 km
    oh kijk aan, top zeg!

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren