Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 10 van 10

Onderwerp: Cijfer zoeken in een verzameling cijfers in excel

  1. #1
    Vraag is opgelost

    Cijfer zoeken in een verzameling cijfers in excel

    Leden,

    Ik zit met het volgende probleem:

    Ik doe er maar gelijk de bijlage bij

    [ATTACH]333693[/ATTACH]

    Het is de bedoeling dat in B4 wordt gezocht naar het cijfer 1 in het ratjetoe B7 t/m J12 en als de 1 is gevonden dan in B4 een 1 zet. Zo ook in C2. Maar die moet dan zoeken naar de 2, enz.
    Ik ben al begonnen met =ALS(OF(B7=1;B8=1;B9=1;B10=1;B11=1;B12=1);1;0) maar dat wordt een formule van hier tot Tokio en weer terug, zo lang.
    Met = VERT.ZOEKEN lukt het niet wat ik wil.

    Heeft er iemand een suggestie hoe ik dit voor elkaar kan krijgen?

    In blijde afwachting van een oplossing,

    groet,
    Johan3h
    Bijgevoegde bestanden Bijgevoegde bestanden
    Laatst aangepast door Johan3h : 11 januari 2019 om 15:15

  2. #2
    Mega Senior
    Verenigingslid
    SjonR's avatar
    Geregistreerd
    10 november 2016
    Locatie
    Zaandam
    Afstand tot server
    ±116 km
    deze in B4 en dan naar rechts doorvoeren?

    PHP Code:
    1
    
    =ALS(AANTAL.ALS(B7:B12;B2);B2;0)
    Bijgevoegde bestanden Bijgevoegde bestanden
    Laatst aangepast door SjonR : 11 januari 2019 om 14:26

  3. #3
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    of:
    Code:
    =B2*(AANTAL.ALS(B7:B12;B2)>0)
    Laatst aangepast door AlexCEL : 11 januari 2019 om 14:34
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  4. #4
    Senior Member
    Geregistreerd
    24 oktober 2012
    voldoet deze formule?

    in B4 plaatsen en dan doortrekken naar K4

    Code:
    =ALS(AANTAL.ALS(B$7:B$12;B2)>0;1;0)

  5. #5
    Moderator
    Verenigingslid

    Geregistreerd
    12 juni 2008
    De suggestie van SjonR vereenvoudigd:

    PHP Code:
    1
    
    =COUNTIF(B7:B12;B2)*B2
    VBA voor smarties
    VBA is een taal die je moet leren met een grammatica- en een woordenboek.

    http://www.helpmij.nl/forum/announcement.php?f=5
    Plaats svp geen bestanden op andere sites; nadat het bestand daar verwijderd is wordt een forumdraad onbegrijpelijk voor anderen.

  6. #6
    Dank voor de snelle reactie,

    Met jullie suggesties zoekt B4 alleen in B7 t/m B12 en dat werkt prima.
    B4 moet echter ook in C7 t/m C12 en in D7 t/m D12, enz zoeken. en dan in B4 het cijfer 1 zetten als resultaat.
    Als ik de formule probeer uit te breiden, dan heb ik weer te veel argumenten of zijn er te veel of te weinig haakjes.

    Ik kom er dus (nog) niet uit helaas.

    Wellicht ter verduidelijking van wat ik wil bereiken lukt wel met de ellenlange formule: =ALS(OF($7=1;B8=1;B9=1;B10=1;B11=1;B12=1;C7=1;C8=1;C9=1;C10=1;C11=1;C12=1;D7=1;D8=1; enz; enz t/m J12 );1;0)
    Daar zit waarschijnlijk de verwarring. In mijn vraag geef ik aan B7 t/m B12 dit moet echter zijn B7 t/m J12, waarbij de kolommen afzonderlijk zijn.

    Sorry voor de verwarring!
    Laatst aangepast door Johan3h : 11 januari 2019 om 15:14

  7. #7
    Moderator
    Verenigingslid

    Geregistreerd
    12 juni 2008
    Probeer de formule eens aan te passen (niet uitbreiden).
    VBA voor smarties
    VBA is een taal die je moet leren met een grammatica- en een woordenboek.

    http://www.helpmij.nl/forum/announcement.php?f=5
    Plaats svp geen bestanden op andere sites; nadat het bestand daar verwijderd is wordt een forumdraad onbegrijpelijk voor anderen.

  8. #8
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Hij moet dus in alle cijfers zoeken en niet alleen in de eigen kolom? Simpel, pas het bereik van de AANTAL.ALS aan en zet deze vast.
    Code:
    =B2*(AANTAL.ALS($B$7:$K$12;B2)>0)
    Laatst aangepast door AlexCEL : 11 januari 2019 om 15:05
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  9. #9
    Senior Member
    Verenigingslid
    JanBG's avatar
    Geregistreerd
    30 augustus 2017
    Locatie
    Flevoland
    Deze in B4 en dan naar rechts doortrekken:

    Code:
    =ALS(AANTAL.ALS($B$7:$J$12;B2)>0;1;0)
    You're never wrong to do the right thing

    Mark Twain

  10. #10
    Thx leden,

    Zowel de formule van AlexCEL als JanBG werken prima.
    Die van Alex geeft mij netjes het getal wat ik zoek, die van Jan simpelweg een 1. Helemaal TOP!!

    Hartelijk dank voor het meedenken en doen allemaal!!

    Groet en een fijn weekend,
    Johan3h

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren