Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 3 van 3

Onderwerp: Als cel is leeg; dan andere cel is leeg; anders formule

  1. #1
    Junior Member
    Geregistreerd
    3 september 2015
    Vraag is opgelost

    Als cel is leeg; dan andere cel is leeg; anders formule

    Na lang proberen, ook met voorbeelden van deze site, toch maar mijn probleem geplaatst.

    Zie bijlage.
    Formule moet worden: Als B4 is leeg; dan moet B5 leeg zijn; anders B5 = B3-B4. Toch lastiger dan ik dacht.

    Voor het eerste deel (WAAR) heb ik:
    =ALS(ISLEEG(B4);B5="")
    alleen verschijnt er dan in B5 i.p.v. een lege cel: € 0,00...? Het enige wat ik met B4 heb gedaan, is de Celeigenschap "Valuta" toegevoegd. Als ik deze Celeigenschap weg haal, verschijnt er in B5: 0.
    Vraag 1) Hoe krijg ik cel B5 echt helemaal leeg?


    Voor het tweede deel (ONWAAR) heb ik dan de volledige formule:
    =ALS(ISLEEG(B4);B5="";B3-B4)
    * Voor B5 werkt dit wel. Ook als ik in B4 andere getallen invoer en op enter druk, wordt de waarde in B5 netjes aangepast.
    ** Maar als ik in B4 eerst een getal heb ingevoerd en dit later verwijder (dus B4 leeg maak), dan blijft in B5 het resultaat van de laatste berekening staan i.p.v. dat B5 leeg is...
    Vraag 2) Hoe wordt B5 in dit laatste geval weer leeg?

    Voorbeelden in de laatste twee gevallen:

    * (Deze is goed)
    B3 500
    B4 200
    B5 300

    ** (Hoe wordt B5 weer leeg?)
    B3 500
    B4
    B5 300

    Hopelijk is dit duidelijk.
    Bij voorbaat dank voor jullie antwoorden!!!
    Laatst aangepast door snb : 14 januari 2019 om 11:22

  2. #2
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Als je er nu eens dit van maakt? Als je in B5 een formule zet die naar B5 verwijst krijg je kringverwijzingen.
    Code:
    =ALS(ISLEEG(B4);"";B3-B4)
    En controleer even of de sheet op automatisch berekenen staat via Bestand > Opties > Formules > Berekeningsopties > bullet voor Automatisch zetten (als dit niet zo is ingesteld).
    Laatst aangepast door AlexCEL : 14 januari 2019 om 07:05
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  3. #3
    Junior Member
    Geregistreerd
    3 september 2015
    Probleem opgelost!
    Bedankt voor deze snelle oplossing AlexCEL!!!
    Laatst aangepast door snb : 14 januari 2019 om 11:35

  4. Dit topic is automatisch gesloten omdat er sinds vier maanden niet meer op gereageerd is.

    Indien gewenst kan de topicstarter een verzoek tot heropening indienen.

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren