Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 8 van 8

Onderwerp: Celbereik in formule bij slepen op laten lopen met meer van één regel

  1. #1
    Junior Member
    Geregistreerd
    17 maart 2019
    Vraag is niet opgelost

    Question Celbereik in formule bij slepen op laten lopen met meer van één regel

    Van een formule die het gemiddelde van een celbereik moet geven wil ik het celbereik steeds met 1536 regels laten oplopen wanneer ik deze formule kopieer door middel van slepen.
    Alle data (getallen) staan in kolom B, meer dan 220000 regels diep. Het eerste celbereik is (B2:B1537), het tweede (B1538:B3073), enz. De verzameling gemiddelden moeten bovenaan bij elkaar in het worksheet staan, niet verspreid over meer dan 220000 regels.
    Bij 'gewoon' slepen van de formule maakt het celbereik en stap van één regel, niet 1536 regels. Is dat laatste wel te realiseren?
    Ik hoop dat iemand hier een goede oplossing voor weet.

  2. #2
    Giga Senior
    Verenigingslid
    SjonR's avatar
    Geregistreerd
    10 november 2016
    Locatie
    Zaandam
    Afstand tot server
    ±116 km
    zonder voorbeeld is het niet exact te zeggen maar zo zou het kunnen:

    PHP Code:
    1
    
    =SOM(INDIRECT("B"&(RIJ()*1536)-1536+2&":B"&(RIJ()*1536+1)))

    beginnend op rij 1
    Bijgevoegde bestanden Bijgevoegde bestanden

  3. #3
    Andere optie die ik graag gebruik voor dit soort problemen is met formule verschuiving.

    Even aangehaakt op het bestandje van SjonR, dan heb je beide oplossingen in een testfile..
    Ik gebruik bij rij() functie graag de verwijzing naar RIJ(A1) omdat je daarmee de formule weer loskoppelt van de feitelijke rij waarop je hem plaatst. het rijnummer is alleen maar bedoeld om het de juiste vermenigvuldiging te krijgen.

    PHP Code:
    1
    
    =SOM(VERSCHUIVING($B$2;(RIJ(A1)-1)*1536;0;1536;1))
    Bijgevoegde bestanden Bijgevoegde bestanden

  4. #4
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    We zochten een gemiddelde toch?
    Code:
    =GEMIDDELDE(VERSCHUIVING($B$2;(RIJ(A1)-1)*1536;;1536))
    Jammer dat er geen voorbeeldbestandje bij zit, misschien waren er nog andere slimme oplossingen mogelijk.
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  5. #5
    ja ik wilde ff kijken of iedereen wel zat op te letten

    haha, ik wilde voor mijn test eerst even met som werken en daarna aanpassen maar dat ben ik dus vergeten..

  6. #6
    Giga Honourable Senior Member
    Geregistreerd
    2 maart 2013
    Ik zou een hulpkolom en een draaitabel gebruiken. Zal sneller werken bij 220k rijen dan de volatiele functies INDERECT() en OFFSET(). Voor de oplossingen maakt het overigens niet uit of het om blokken van 1536 rijen of bv 3 rijen gaat. Het principe blijft hetzelfde.

    Zie tab 'Draaitabel'
    Bijgevoegde bestanden Bijgevoegde bestanden
    Je kan een paard naar het water leiden, maar je kan het niet dwingen te drinken.

  7. #7
    Giga Honourable Senior Member HSV's avatar
    Geregistreerd
    18 juli 2008
    Alhoewel ik geen liefhebber ben van gehele kolommen een niet volatile formule.
    Code:
    =GEMIDDELDE(INDEX(B:B;(RIJ(A1)-1)*1536+2):INDEX(B:B;RIJ(A1)*1536+1))
    Laatst aangepast door HSV : 17 maart 2019 om 21:49 Reden: overtollige haken
    ____________
    Met vriendelijke groet,
    Harry

    Lag nooit om de keuzes van dien vraauw, bist ter zulf aine van....
    (Grunnegs-Gronings)

  8. #8
    Junior Member
    Geregistreerd
    17 maart 2019
    Allen, super bedankt voor jullie hulp! Het probleem is opgelost en de oplossingsrichting heb ik ook kunnen gebruiken voor het vinden van max-waarden, min-waarden en het aantal nul-waarden in de oplopende celbereiken.

    Met vriendelijke groet,
    Kees

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren