Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 3 van 3

Onderwerp: Automatisch in januari prijs indexeren met 2%

  1. #1
    Junior Member
    Geregistreerd
    12 februari 2019
    Vraag is opgelost

    Automatisch in januari prijs indexeren met 2%

    Ik heb een excel bestand gemaakt waar ik bedden verhuur. Ik kan de omzet per bed per maand uitrekenen. Maar is het ook mogelijk dat ik deze ieder jaar met 2% ophoog. Afhankelijk van het jaar waar de indexatie in gaat.

    In dit voorbeeld mag er pas vanaf 01-01-2022 in de maand januari met 2% worden geïndexeerd

    De variabelen heb ik ingegeven in een tabblad Variabelen.

    De output probeer ik weergegeven in het tabblad basisgegevens.

    Hoop dat de bijlage duidelijk is.
    Bijgevoegde bestanden Bijgevoegde bestanden

  2. #2
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Allereerst, wat een vreselijk ingewikkelde en overbodig lange functie om een maand bij een datum op te tellen, gebruik:
    Code:
    A2: =ZELFDE.DAG(A2;1)
    Dan voor het echte probleem:
    Code:
    B2: =ALS($A2<Variabelen!$B$9;0;Variabelen!$B$3*(Variabelen!$B$4*52)/12)*ALS(A2<Variabelen!$B$6;1;(1+Variabelen!$B$5)^(JAAR(A2)-JAAR(Variabelen!$B$6)+1))
    Heb aangenomen dat de indexering altijd op 1 januari van het jaar plaatsvindt.
    Bijgevoegde bestanden Bijgevoegde bestanden
    Laatst aangepast door AlexCEL : 15 april 2019 om 20:29
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  3. #3
    Junior Member
    Geregistreerd
    12 februari 2019

    Indexering

    Ik had de eerste formule staan omdat de start niet altijd op de eerste dag van de maand is en de volgende maand wel altijd moet starten op de eerste dag van de maand.

    De code voor mijn echt probleem is echt geweldig. Werkt perfect. Is het mogelijk dat u beschrijft wat u deed. Kan ik deze misschien in de toekomst ook zelf opzetten.

    Stel dat de indexering niet altijd op 1 januari is maar bijvoorbeeld op 1 juni?

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren