Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Pagina 1 van 2 1 2 LaatsteLaatste
Weergeven resultaten 1 tot 20 van 21

Onderwerp: Excel formules pas laten werken op basis van tekst in Kolom 1

  1. #1
    Vraag is opgelost

    Excel formules pas laten werken op basis van tekst in Kolom 1

    Goedemorgen,

    Ik zit met het volgende probleem.
    Ik heb meerdere kolommen (24 stuks) staan met allerlei formules, o.a. verticaal zoeken, aantallen.als, som.als etc.
    Nu wil ik op basis van een tekst in kolom 1 alle formules in de kolommen pas laten werken indien er in kolom 1 een specifiek woord staat.

    Weet iemand hier een oplossing voor?

    Ik hoor het graag
    Mvg.
    Projectstarter

  2. #2
    Senior Member Gijsbert1's avatar
    Geregistreerd
    7 april 2016
    Locatie
    Krimpen aan den IJssel
    Afstand tot server
    ±139 km
    Code:
    =ALS(kolom1="specifiek woord";(hier formule);"")

  3. #3
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Deze kijkt of een "een bepaald woord" in een zin in "een cel" voorkomt. Is dat de bedoeling?
    Code:
    =ALS(ISGETAL(VIND.SPEC("een bepaald woord";een cel));"formule";"")
    Of is het woord exact terug te vinden in een cel? Dan deze misschien:
    Code:
    =ALS(AANTAL.ALS(A:A;"een bepaald woord");"formule";"")
    Of moet het woord in "een kolom" in "een zin" voorkomen? Dan vorige iets uitbreiden
    Code:
    =ALS(AANTAL.ALS(A:A;"*een bepaald woord*");"formule";"")
    Vragen, vragen...

    Leer jezelf aan een voorbeeld te plaatsen bij een vraag. Dan krijg je vaak meteen een werkend antwoord...
    Laatst aangepast door AlexCEL : 16 april 2019 om 08:30
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  4. #4
    Goedemorgen Gijsbert en Alexcel,

    Bedankt voor jullie reacties!
    Inderdaad zegt een voorbeeld bestand veel meer, ik zal er in het vervolg een voorbeeld bij doen.
    Bijgevoegd dan ook het voorbeeld bestand.

    Hopelijk kun je mij ermee helpen.

    Alvast bedankt!

    Mvg.
    Projectstarter
    Bijgevoegde bestanden Bijgevoegde bestanden

  5. #5
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Post #2 toegepast:
    Code:
    K6 =ALS(A6="CAST";VERT.ZOEKEN(C6;'Sheet 2'!$A$1:$C$1994;1;1);"")
    Rest van de kolommen gaat net zo.
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  6. #6
    Senior Member
    Geregistreerd
    23 mei 2013
    zie voorbeeld in kolom K en L
    Bijgevoegde bestanden Bijgevoegde bestanden

  7. #7
    Bedankt Alexcel!
    Dit werkt heel goed, reuze bedankt!
    Laatste vraag:
    Mocht ik nog een ander woord naast "CAST" willen hebben, bijvoorbeeld "OUT" hoe pas ik de formule dan aan?
    Dus de formules laten werken op basis van 2 of meer verschillende woorden.

  8. #8
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Zo misschien?
    Code:
    =ALS(OF(A6="CAST";A6="OUT");VERT.ZOEKEN(C6;'Sheet 2'!$A$1:$C$1994;1;1);"")
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  9. #9
    Hallo Alexcel,

    Werkt weer super, bedankt!
    Nog 1 issue:
    Ik moet ook nog een verticaal zoekfunctie hebben op basis van een gedeelte tekst uit een veld, zie bijlage voorbeeld.

    Wat is de juiste formule hiervoor?

    Je zou je me weer enorm helpen.

    Mvg.
    Projectstarter
    Bijgevoegde bestanden Bijgevoegde bestanden

  10. #10
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Dit moet je toch even toelichten. Waarom horen die 2 bij elkaar? Alleen door het nummer dat erachter staat? VERT.ZOEKEN in 1 kolom is niet logisch.
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  11. #11
    ik wil op basis van cel B2 de groep (celA2) vanuit blad 2 in cel C2 hebben.
    Op basis van de groep die ik dan op blad 1 heb kan ik weer verder met andere formules.

  12. #12
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Dat snap ik. Dat stond reeds in de toelichting in de sheet.

    Daarom herhaal ik de vraag: waarom hoort de naam "B Spec den-001" bij de groep "B Spec den". Alleen door het nummer dat erachter staat? Werkt dit ook zo voor andere "groepen", het voorbeeld is erg summier op dit gebied. Als dit wel zo werkt hoef je alleen het volgnummer eraf te halen en heb je de groep toch? Bijvoorbeeld zo:
    Code:
    =LINKS(B2;LENGTE(B2)-4)
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  13. #13
    Goedemorgen AlexCel,

    Sorry dat het nog niet duidelijk is, ik ga het nog een keer proberen.
    Jouw formule had ik ook bedacht echter verandert het aantal tekens telkens.
    Zie bijlage met een aangepast bestand, de ene keer is het meer en de ander keer weer minder tekens, dat is de moeilijkheid.

    Ik heb eigenlijk een functie nodig die een bepaalde herkenning bied op de beste overeenkomst.

    Hopelijk kun je er iets mee.

    Bedankt voor je steun, dit wordt zeer gewaardeerd.
    Mvg.
    Bijgevoegde bestanden Bijgevoegde bestanden

  14. #14
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Dit wat je zoekt?
    Code:
    C2: =ALS.FOUT(INDEX(Blad2!$A:$A;SOMPRODUCT(ISGETAL(VIND.SPEC(Blad2!$A$2:$A$4;$B2))*RIJ($2:$4)));"-")
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  15. #15
    Mega Honourable Senior Member popipipo's avatar
    Geregistreerd
    21 november 2006
    Code:
    =VLOOKUP(LEFT(B2;5)&"*";Blad2!A:A;1;0)
    Probeer het eens met deze formule
    Willem

    25 % van de oplossing is het juist formuleren van de vraag.
    25 % van de oplossing is het juist lezen van de vraag.
    25 % van de oplossing is het xls voorbeeldje bij de vraag.
    25 % van de oplossing is het antwoord op de vraag.

  16. #16
    Hallo AlexCel en Popipipo,

    Bedankt weer voor jullie antwoorden.
    Sorry Popipino, de oplossing van Alexcel komt het dichtste in de buurt van de oplossing.

    Maar AlexCel nog niet helemaal.
    Je formule werkt inderdaad! Knap gedaan.
    Kun je de formule aanpassen? Het komt in mijn altijd voor dat de groep op blad 2 niet op dezelfde rij staat.

    Zie bijgevoegd bestand.

    Thanks!
    Mvg.
    Bijgevoegde bestanden Bijgevoegde bestanden

  17. #17
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Aangepaste formule:
    Code:
    =ALS.FOUT(INDEX(Blad2!A:A;SOMPRODUCT((Blad2!A$2:A$11<>"")*ISGETAL(VIND.SPEC(Blad2!A$2:A$11;B2))*RIJ($2:$11)));"-")
    Die van popipipo is in de nieuwe situatie met de lege rijen ertussen handiger in het gebruik denk ik... (simpeler)
    Code:
    =ALS.FOUT(VERT.ZOEKEN(LINKS(B2;5)&"*";Blad2!A:A;1;0);"-")
    Of een daarop geïnspireerde oplossing:
    Code:
    =ALS.FOUT(INDEX(Blad2!A:A;VERGELIJKEN(LINKS(B2;5)&"*";Blad2!A:A;0));"-")
    Laatst aangepast door AlexCEL : 17 april 2019 om 12:53
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  18. #18
    Hallo Alexcel,

    ik sta versteld, echt heel knap gedaan weer. Werkt!
    Welke optie werkt het veiligst, beste?
    En waar staat bij (B2;5) de "5" voor in de formules?

    Mvg

  19. #19
    Hallo AlexCel en Popipipo,

    In de tussentijd ben ik verder gegaan.
    Ik kan uit de voeten met alle geboden oplossingen.

    Bedankt voor jullie inzet!
    Mvg.
    Projectstarter

  20. #20
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Mooi zo.

    Nog ter info, voor als je het nog niet uitgevogeld zou hebben, LINKS(B2;5) betekend dat de eerste 5 tekens van B2 (gecombineerd met een "*") gebruikt worden om te zoeken in de lijst op blad2.
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren