Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 11 van 11

Onderwerp: Afronden op *.*0 of *,*5 eurocent

  1. #1
    Senior Member
    Geregistreerd
    27 april 2016
    Vraag is niet opgelost

    Afronden op *.*0 of *,*5 eurocent

    Goedenavond,

    Ik heb een formule die werkt zoals het moet, maar nu zou ik deze willen laten afronden op 0 of 5 eurocent.
    Heb het al geprobeerd met afronden(0.234,0.05) al vast bedankt.

    HTML Code:
    1
    
    =ALS($A17>=$E38;(A17*I19)*Urenlijst!CS5;($A17*$I19))

  2. #2
    Giga Senior Haije's avatar
    Geregistreerd
    24 maart 2009
    Locatie
    Oldenzaal
    Afstand tot server
    ±97 km
    probeer het eens met AFRONDEN.N.VEELVOUD
    Haije
    ___________________________________________________

  3. #3
    Senior Member
    Geregistreerd
    27 april 2016
    HTML Code:
    1
    
    =ALS($A17>=$E38;(A17*I19)*Urenlijst!CS5;AFRONDEN.N.VEELVOUD($A17*$I19;0,05))

    Nog steeds geeft hij € 34.69 aan .... wat doe ik fout!!

  4. #4
    Giga Honourable Senior Member
    Geregistreerd
    2 maart 2013
    Wat denk je zelf? Vandaag voor het eerst op dit forum?

    https://www.helpmij.nl/forum/announcement.php?f=5
    Laatst aangepast door VenA : 15 mei 2019 om 19:38
    Je kan een paard naar het water leiden, maar je kan het niet dwingen te drinken.

  5. #5
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Je hebt de aangedragen oplossing in het ONWAAR-gedeelte van de ALS-functie gezet. M.a.w. de AFRONDEN functie werkt alleen als A17<E38.

    Een voorbeeld zou zeker helpen met testen, nu moet je zelf uitvogelen of deze werkt zoals je bedoelt:
    Code:
    =ALS($A17>=$E38;AFRONDEN.N.VEELVOUD(($A17*$I19)*Urenlijst!CS5;0,05));"hier komt te staan wat er moet gebeuren als A17<E38")
    Laatst aangepast door AlexCEL : 15 mei 2019 om 19:54
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  6. #6
    Senior Member
    Geregistreerd
    27 april 2016
    Hier bij het voorbeeld, sorry niet aan gedacht.
    Bijgevoegde bestanden Bijgevoegde bestanden

  7. #7
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Waarom heb je niets gedaan met de informatie in #5?
    Code:
    =ALS($A9>=$E18;AFRONDEN.N.VEELVOUD($A9*$I11*R4;0,05))
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  8. #8
    Senior Member
    Geregistreerd
    27 april 2016
    Maar nu krijg ik als A17 kleiner is dan E38 dan krijg ik ONWAAR

  9. #9
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Waarom heb je post #5 nog steeds niet gelezen?
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  10. #10
    Ik zou het iets anders noteren, scheelt herhaling van de berekening en leest wat prettiger


    Code:
    =AFRONDEN.N.VEELVOUD($A9*$I11*ALS($A9>=$E18;R4;1);0,05)
    de als-voorwaarde leid immers niet tot een andere grondslag (maar alleen tot een toeslag op de grondslag

    ik zou ALS alleen aan het begin zetten als het in een onwaar scenario tot een heel andere formule zou leiden. nu is het duidelijker dat er alleen een toeslag geldt als aan de voorwaarde is voldaan
    Laatst aangepast door roeljongman : 15 mei 2019 om 20:54

  11. #11
    Senior Member
    Geregistreerd
    27 april 2016
    Super bedankt de laatste werkt zoals ik graag wilde.
    vriendelijk bedankt

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren