Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 10 van 10

Onderwerp: Formule veranderd

  1. #1
    Senior Member
    Geregistreerd
    25 november 2012
    Vraag is niet opgelost

    Formule veranderd

    Goedemiddag,

    Ik heb een bestandje met meerdere tabbladen gemaakt.

    In de eerste plak ik ruwe data die ik via een macro helemaal goed zet.
    Tot zover is er niets aan de hand.

    In de 2e staat in elke cel een formule voor verticaal zoeken.
    Maar elke keer als ik de ruwe data inlees en de macro er overheen gooi, worden automatisch deze formules aangepast.
    Ook al zet ik $ op verschillende plaatsen.

    Code:
    =VERT.ZOEKEN(B2;'Inlees Tabblad'!$A$2:$W$59;20;ONWAAR)
    .

    is er een manier om ervoor te zorgen dat de code gewoon blijft zoals hij hier staat?

    Ik heb nog geen tijd voor een voorbeeld bestandje, dus hoop dat iemand mij zo kan helpen.

    Alvast bedankt.
    MvrGrt Michel

    Een uitleg bij de oplossing is niet verplicht maar wel van harte welkom.
    Daar wil ik graag van leren!

    Een dag niet gelachen is een dag niet geleefd.

  2. #2
    je zult waarschijnlijk je macro aan moeten passen zodat deze de wijziging van de formule niet triggert. zonder voorbeeld en zonder code gaat dit niet lukken..

  3. #3
    Mega Honourable Senior Member popipipo's avatar
    Geregistreerd
    21 november 2006
    Ik heb een bestandje met meerdere tabbladen gemaakt.
    Ik heb nog geen tijd voor een voorbeeld bestandje
    Is dit niet een beetje tegenstrijdig.

    Als jij geen tijd hebt voor een bestandje dan moeten wij het bestandje maken en daar hebben wij geen tijd voor.
    Willem

    25 % van de oplossing is het juist formuleren van de vraag.
    25 % van de oplossing is het juist lezen van de vraag.
    25 % van de oplossing is het xls voorbeeldje bij de vraag.
    25 % van de oplossing is het antwoord op de vraag.

  4. #4
    Senior Member
    Geregistreerd
    25 november 2012
    Quote Origineel gepost door popipipo Bekijk Bericht

    Als jij geen tijd hebt voor een bestandje dan moeten wij het bestandje maken en daar hebben wij geen tijd voor.
    Ik was bezig op het werk toen ik dit berichtje maakte. Dus even geen tijd. Verder onthoud ik me van alle commentaar.

  5. #5
    Senior Member
    Geregistreerd
    25 november 2012
    Quote Origineel gepost door roeljongman Bekijk Bericht
    je zult waarschijnlijk je macro aan moeten passen zodat deze de wijziging van de formule niet triggert. zonder voorbeeld en zonder code gaat dit niet lukken..
    Bedankt voor je reactie. Zal zo het bestandje iets aanpassen ivm de privacy en dan zal ik het bestandje even uploaden!

  6. #6
    Giga Senior
    Verenigingslid

    Geregistreerd
    19 april 2007
    Locatie
    den haag
    Afstand tot server
    ±111 km
    misschien als je indirect gebruikt in je formule
    groeten Sylvester Ponten

    ik gebruik Ms Windows 10 en excel 2010

  7. #7
    Senior Member
    Geregistreerd
    25 november 2012

    Bestandje

    Hoi allemaal,

    Ik heb het bestandje even aangepast om geen privacy te schenden, maar dat is gelukt.

    Hopelijk kunnen jullie mij helpen.

    De 'indirect' functie ken ik nog niet, dat ga ik ook even uitzoeken.

    Alvast bedankt voor het meedenken!
    Bijgevoegde bestanden Bijgevoegde bestanden
    MvrGrt Michel

    Een uitleg bij de oplossing is niet verplicht maar wel van harte welkom.
    Daar wil ik graag van leren!

    Een dag niet gelachen is een dag niet geleefd.

  8. #8
    Senior Member
    Geregistreerd
    25 november 2012
    Quote Origineel gepost door sylvester-ponte Bekijk Bericht
    misschien als je indirect gebruikt in je formule

    Hoe zou ik de indirect moeten plaatsten in deze code dan? Als ik namelijk alles bekijk veranderd de "W" in de formule naar een "M" en daardoor geeft ie een fout. Als ik handmatig de M in een W verander komt de juiste informatie er weer te staan.

    Code:
    =VERT.ZOEKEN(B2;'Inlees Tabblad'!$A$2:$W$59;20;ONWAAR)
    MvrGrt Michel

    Een uitleg bij de oplossing is niet verplicht maar wel van harte welkom.
    Daar wil ik graag van leren!

    Een dag niet gelachen is een dag niet geleefd.

  9. #9
    Mega Honourable Senior Member popipipo's avatar
    Geregistreerd
    21 november 2006
    Waarom de tussen stap van eerst 'inhoud kopieren' naar 'inlees tabblad' en dan pas naar 'Resultaat'

    De tussen stap naar 'inlees tabblad' kun je natuurlijk ook overslaan.
    Dus rechtstreeks van 'inhoud kopieren' naar 'Resultaat'

    Je hebt dan geen probleem meer met je macro's die kolommen verwijderd en daardoor de formules aangepast worden.
    Code:
    =INDEX('Inhoud kopieren'!$B$13:$DA$30;MATCH($A4;'Inhoud kopieren'!$A$13:$A$30;0);MATCH(B$1;'Inhoud kopieren'!$B$12:$DA$12;0))
    Zorg er dan wel voor dat de kop titels gelijk zijn.
    Willem

    25 % van de oplossing is het juist formuleren van de vraag.
    25 % van de oplossing is het juist lezen van de vraag.
    25 % van de oplossing is het xls voorbeeldje bij de vraag.
    25 % van de oplossing is het antwoord op de vraag.

  10. #10
    Giga Honourable Senior Member
    Geregistreerd
    2 maart 2013
    Ook met een macro is het prima te doen zonder tussenblad. Ik kan alleen de gegevens van de groene kaart niet vinden en 1 regel aan data is niet echt handig om het te testen.

    Code:
    Sub VenA()
      ar = Sheets("Inhoud kopieren").Cells(12, 1).CurrentRegion.Offset(1)
      d = Split("6 19 20 61 72")
      For j = 1 To UBound(ar)
        ar(j, 3) = IIf(ar(j, 7) = 4, "Taxi", IIf(ar(j, 10) = "j", "Rolstoelbus", "Bus")) 'Een willekeurige lege kolom voor het bepalen van het soort taxi 
        ar(j, 17) = "??" 'Groene kaart in een willekeurige lege kolom
        For jj = 0 To UBound(d)
          If IsDate(ar(j, d(jj))) Then ar(j, d(jj)) = Format(ar(j, d(jj)), "mm-dd-yyyy")
        Next jj
      Next j
      With Sheets("Resultaat").Cells(1).CurrentRegion.Offset(1)
        .Clear
        .Offset(, 1).Resize(UBound(ar) - 1, 14) = Application.Index(ar, 0, Array(1, 81, 67, 3, 7, 61, 82, 19, 20, 17, 72, 69, 5, 6))
      End With
    End Sub
    Bijgevoegde bestanden Bijgevoegde bestanden
    Je kan een paard naar het water leiden, maar je kan het niet dwingen te drinken.

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren