Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 3 van 3

Onderwerp: vind.spec maar dan over meerdere cellen

  1. #1
    Vraag is niet opgelost

    vind.spec maar dan over meerdere cellen

    Beste,

    Ik ben bezig met een script wat heel veel dingen doet, data structureert, formules maakt en lijstjes weergeeft. Tot daar geen problemen.

    Maar nu ben ik bezig met het maken van een lijstje waar hoeveelheden achter moeten komen te staan en daar kom ik niet uit. Het lijstje gaat me lukken, maar de hoeveelheden zit ik mee te worstelen.

    Ik heb een kolom met in de cellen gegevens gescheiden door een "|", iedere cel in die kolom kan die gegevens bevatten en die gegevens kunnen overal verschillen. Ik maak via vba al een lijst met unieke waarden die daarin voorkomen, en die unieke waarden geef ik weer onder mijn data.

    Voorbeeld van de data in een cel:
    Code:
    Stompe deur|Gedateerd|Klemt|Goed in de verf
    Stompe deur|Nieuw|Grondverf
    Opdek deur|Goed|Matig in de verf
    Zomaar 3 cellen uit mijn range. Nu wil ik weten hoe vaak het woord "Klemt" voorkomt in deze range. Normaal op een cel zou ik dit doen met vind.spec>0 dan +1, maar dat gaat niet op voor een range... Een Matrix-formule werkt hier niet (tenminste wat ik probeer)...

    Iemand een mooie oplossing?
    Alvast bedankt!
    Als ik het wist, dan had ik het niet gevraagd...

  2. #2
    Giga Honourable Senior Member
    Geregistreerd
    2 maart 2013
    Code:
    =AANTAL.ALS(A1:A3;"*klemt*")
    Je kan een paard naar het water leiden, maar je kan het niet dwingen te drinken.

  3. #3
    Een hoekje in kruipend, met het schaamrood op mijn kaken...

    Bedankt! Hoe simpel kan het soms zijn terwijl je heel ingewikkeld zit te denken...
    Als ik het wist, dan had ik het niet gevraagd...

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren