Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 8 van 8

Onderwerp: ISNB leidt tot te veel argumenten

  1. #1
    Vraag is niet opgelost

    ISNB leidt tot te veel argumenten

    hallo,

    Ik heb onderstaande formule. deze werkt prima. Echter, in sommige gevallen krijg ik in plaats van een 0, #N/B. Daarom wil ik een ISNB toevoegen.

    =ALS(Input!Q2=1;ALS(ZOEKEN($I2&"0"&$F2&W$1;Lessen!$A$2:Lessen!$A$134)=$I2&"0"&$F2&W$1;$I2&"0"&$F2&W$ 1;ALS(ZOEKEN($J2&"0"&$F2&W$1;Lessen!$A$2:Lessen!$A$134)=$J2&"0"&$F2&W$1;$J2&"0"&$F2&W$1;ALS(ZOEKEN($ K2&"0"&$F2&W$1;Lessen!$A$2:Lessen!$A$134)=$K2&"0"&$F2&W$1;$K2&"0"&$F2&W$1))

    de ISNB in de formule is als volgt:

    =ALS(ISNB(Input!Q2=1;ALS(ZOEKEN($I2&"0"&$F2&W$1;Lessen!$A$2:Lessen!$A$134)=$I2&"0"&$F2&W$1;$I2&"0"&$ F2&W$1;ALS(ZOEKEN($J2&"0"&$F2&W$1;Lessen!$A$2:Lessen!$A$134)=$J2&"0"&$F2&W$1;$J2&"0"&$F2&W$1;ALS(ZOE KEN($K2&"0"&$F2&W$1;Lessen!$A$2:Lessen!$A$134)=$K2&"0"&$F2&W$1;$K2&"0"&$F2&W$1));"0";Input!Q2=1;ALS(ZOEKEN($I2&"0"&$F2&W$1;Lessen!$A$2:Lessen!$A$134)=$I2&"0"&$F2&W$1;$I2&"0"&$F2&W$ 1;ALS(ZOEKEN($J2&"0"&$F2&W$1;Lessen!$A$2:Lessen!$A$134)=$J2&"0"&$F2&W$1;$J2&"0"&$F2&W$1;ALS(ZOEKEN($ K2&"0"&$F2&W$1;Lessen!$A$2:Lessen!$A$134)=$K2&"0"&$F2&W$1;$K2&"0"&$F2&W$1))

    helaas krijg ik bij deze formule de melding "u hebt voor deze functie te veel argumenten ingevoerd."

    kan iemand mij hiermee helpen?

    alvast dank.

  2. #2
    Giga Senior
    Verenigingslid
    SjonR's avatar
    Geregistreerd
    10 november 2016
    Locatie
    Zaandam
    Afstand tot server
    ±116 km
    En de ALS nesten in de ISNB?

  3. #3
    sorry, ik zou niet weten hoe ik dit zou moeten doen. zou je hier een voorbeeld van kunnen geven?

  4. #4
    Gebruik een ALS.NB()* ipv een ISNB(), dat voorkomt ook herhaling van de hele ALS-reeks.

    =ALS.NB(ALS(Input!Q2=1;ALS(ZOEKEN($I2&"0"&$F2&W$1;Lessen!$A$2:Lessen!$A$134)=$I2&"0"&$F2&W$1;$I2&"0"&$F2&W$1 ;ALS(ZOEKEN($J2&"0"&$F2&W$1;Lessen!$A$2:Lessen!$A$134)=$J2&"0"&$F2&W$1;$J2&"0"&$F2&W$1;ALS(ZOEKEN($K 2&"0"&$F2&W$1;Lessen!$A$2:Lessen!$A$134)=$K2&"0"&$F2&W$1;$K2&"0"&$F2&W$1;))););0)

    Daarnaast lijkt je formule onnodig complex maar dat is zonder voorbeeld bestand niet goed te beoordelen.




    _________
    *) de functie ALS.NB is beschikbaar vanaf versie Excel 2013

  5. #5
    Ik kan helaas geen voorbeeld bestand sturen, daar het gaat om persoonsgegevens. Helaas lijkt de formule ook niet te werken. De geschreven waarde blijft #N/B

  6. #6
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Niemand vraagt om je originele bestand. We willen graag een representatief voorbeeldbestand met aap, noot, mies-gegevens.
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  7. #7
    in het voorbeeld is in de tab database W2 de plek waar de aangeapste formule met ALS.NB staat.
    De originele formule staat in alle andere cellen tussen L2 en BC21.

    Het lijkt met de oude formule overal goed te geen, met uitzondering van de cellen met #N/B als resultaat.
    Bijgevoegde bestanden Bijgevoegde bestanden

  8. #8
    Welke excel versie gebruik je? ik zie namelijk een #naam fout en dat kan erop wijzen dat de functie in jou versie nog niet bestaat. zoals ik in mijn eerste reactie zette, deze ALS.NB is beschikbaar vanaf 2013 versie.

    andere optie is dat er bij het kopieren en plakken een foutje in is geslopen (extra spatie of ander onzichtbaar leesteken), waardoor de formule niet wordt herkend.
    voor de zekerheid de bijlage geupload met voor heel kolom W de nieuwe formule die bij mij nu wel werkt en overal 0 toont ipv #N/B
    Bijgevoegde bestanden Bijgevoegde bestanden
    Laatst aangepast door roeljongman : 12 juni 2019 om 16:13

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren