Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 11 van 11

Onderwerp: Weeknummer naar maand

  1. #1
    Junior Member
    Geregistreerd
    18 september 2012
    Vraag is niet opgelost

    Weeknummer naar maand

    Goedendag, voor de juiste verwerking van gegevens ben ik op zoek naar een formule welke de maand uit een weeknummer kan halen. Op het forum kom ik deze vraag meer tegen maar niet in combinatie met de verschillen in de jaartallen waar ik nu tegen aanloop.

    Het probleem waar ik tegen aanloop is dat maandag 31-12-2018 valt in week 1 en in onze boekhoud software valt dit in boekjaar 2019. Het zelfde doet zich aan het einde van het jaar ook weer voor, 30 en 31 december 2019 vallen in boekjaar 2020.

    Ik zou graag middels een formule obv boekjaar 2019 en weeknummer 1 de uitkomst 2019/01 willen hebben. De 01 staat dan voor januari.

    Graag jullie reacties
    Bijgevoegde bestanden Bijgevoegde bestanden

  2. #2
    Senior Member
    Donateur
    DANIEL162's avatar
    Geregistreerd
    24 februari 2011
    Locatie
    Ieper
    Afstand tot server
    ±337 km
    Het probleem waar ik tegen aanloop is dat maandag 31-12-2018 valt in week 1
    Dat klopt.
    https://www.kalender-365.nl/kalender-2019.html
    Appletips nl https://www.appletips.nl/
    Nu ook in Belgie - Appleweetjes.be https://appleweetjes.be/

  3. #3
    Junior Member
    Geregistreerd
    18 september 2012
    Bedankt voor je reactie maar dat het klopt, dat snap ik. De vraag is hoe kan ik de formule samenstellen zodat de datum van 31-12-2018 de uitkomst krijgt 2019/JAN of 2019/01

  4. #4
    Senior Member
    Donateur
    DANIEL162's avatar
    Geregistreerd
    24 februari 2011
    Locatie
    Ieper
    Afstand tot server
    ±337 km
    ma, 31-12-2018 2018 2019 1 2019/01 hier gaat het fout
    zo iets?
    =ALS(B11<C11;TEKST(JAAR(A11)+1;"0")&"/"&TEKST(MAAND(A11)-11;"00");ALS(B11=C11;TEKST(JAAR(A11);"0")&"/"&TEKST(MAAND(A11);"00")))

    resultaat:
    ma, 31-12-2018 2018 2019 1 2019/01
    Laatst aangepast door DANIEL162 : 10 september 2019 om 16:02
    Appletips nl https://www.appletips.nl/
    Nu ook in Belgie - Appleweetjes.be https://appleweetjes.be/

  5. #5
    Junior Member
    Geregistreerd
    18 september 2012

    Top, bedankt

    Helemaal goed, bedankt hier kan ik mee verder.

    Slim om de vergelijking tussen de jaren mee te nemen, ik zat veel te ingewikkeld te denken met de weekdagen erbij.

  6. #6
    Senior Member Gijsbert1's avatar
    Geregistreerd
    7 april 2016
    Locatie
    Krimpen aan den IJssel
    Afstand tot server
    ±139 km
    Zonder verwijzing naar kolom B en C:
    Code:
    =IF(ISOWEEKNUM(A11-7)+1=ISOWEEKNUM(A11);TEXT(YEAR(A11);"0")&"/"&TEXT(MONTH(A11);"00");TEXT(YEAR(A11+7);"0")&"/"&TEXT(MONTH(A11+7);"00"))

  7. #7
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Voortbordurend op vorige oplossing, hierbij nog een lekker korte:
    Code:
    *knip*
    Edit: nieuwe versie in post #9.
    Laatst aangepast door AlexCEL : 11 september 2019 om 10:10
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  8. #8
    Senior Member
    Donateur
    DANIEL162's avatar
    Geregistreerd
    24 februari 2011
    Locatie
    Ieper
    Afstand tot server
    ±337 km
    Alex
    Lees de vraag eens goed!
    De vraag is hoe kan ik de formule samenstellen zodat de datum van 31-12-2018 de uitkomst krijgt 2019/JAN of 2019/01
    Bij u is het anders 2018/12
    Appletips nl https://www.appletips.nl/
    Nu ook in Belgie - Appleweetjes.be https://appleweetjes.be/

  9. #9
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    oeps... deze gaat wel naar wens dacht ik.
    Code:
    =TEKST(A20+7*(ISO.WEEKNUMMER(A20-7)+1<>ISO.WEEKNUMMER(A20));"jjjj/mm")
    Bijgevoegde bestanden Bijgevoegde bestanden
    Laatst aangepast door AlexCEL : 11 september 2019 om 10:30 Reden: vb toegevoegd
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  10. #10
    Giga Honourable Senior Member
    Verenigingslid

    Geregistreerd
    12 juni 2008
    PHP Code:
    1
    
    =weeknum(a1;21)&"/" & year(a1-weekday(a1;2)+7)
    VBA voor smarties
    VBA is een taal die je moet leren met een grammatica- en een woordenboek.

    http://www.helpmij.nl/forum/announcement.php?f=5
    Plaats svp geen bestanden op andere sites; nadat het bestand daar verwijderd is wordt een forumdraad onbegrijpelijk voor anderen.

  11. #11
    Senior Member
    Verenigingslid
    Piet Bom's avatar
    Geregistreerd
    13 november 2010
    Locatie
    Fine Earth
    Als het over weeknummers gaat kan ik het niet laten
    Ik had een test tooltje om te zien wat er gebeurd, en het verrast me steeds weer.
    Klik maar eens op de spinner en zie de verrassingen verkleuren............
    Bijgevoegde bestanden Bijgevoegde bestanden
    Met vriendelijke groeten / Kind regards / Mit freundlichen Grüßen / Meilleurs souvenirs / Venlig hilsen / Cordiali saluti / Atentos saludos / Considerações Amáveis / Saygilarimla / مع أطيپ التحيات,
    Piet Bom

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren