Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 9 van 9

Onderwerp: Hulp gevraagd bij het gebruik van de logische functies EN en OF

  1. #1
    Junior Member
    Geregistreerd
    2 december 2019
    Vraag is niet opgelost

    Hulp gevraagd bij het gebruik van de logische functies EN en OF

    Hallo,
    iemand een idee wat ik fout doe in deze formule?
    =ALS(EN(B2="Vlaanderen";C2>=100000)*OF(B2="Wallonië";C2>=75000);"€ 500,00";"")

    Is voor in een tabel waarin een bonus van 500€ te voorzien is als men in vlaanderen een verkoop hoger dan 100000€ heeft behaald en in Wallonië hoger dan 75000€.
    Alle hulp is welkom.

  2. #2
    bedoel je eigenlijk zoiets?

    ps. plaats in het vervolg zelf een voorbeeldje dat werkt makkelijker voor de helpers.
    Bijgevoegde bestanden Bijgevoegde bestanden

  3. #3
    Deze werkt ook volgens mij..

    Code:
    =ALS(C2>=100000*(B2="Wallonië")*0,75;500;0)
    de truc in deze is dat als de uitkomst van (B2="Wallonië") WAAR is dat dit gelijk staat aan 1 en bij ONWAAR gelijk aan 0

  4. #4
    Junior Member
    Geregistreerd
    2 december 2019
    Hallo,

    ik heb even de tabel bijgevoegd...
    Klik op afbeelding voor grotere versie

Naam:  Knipsel.JPG
Bekeken: 14
Grootte:  49,4 KB

    Mijn formule blijkt niet correct te zijn.
    =ALS(EN(B2="Vlaanderen";C2>=100000)*OF(B2="Wallonië";C2=75000);"€500,00";"")
    Laatst aangepast door Toebak : 2 december 2019 om 17:01

  5. #5
    heg je #2 bekeken?

  6. #6
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Plaatjes horen in een photoshop-forum, niet bij een EXCEL-vraag.

    Denk dat je deze zoekt:
    Code:
    =ALS(OF(EN(B2="Vlaanderen";C2>=100000);EN(B2="Wallonië";C2>=75000));"€ 500,00";"")
    Brussel krijgt niets?
    Laatst aangepast door AlexCEL : 2 december 2019 om 17:15
    -- een voorbeeldbestandje zegt meer dan 1000 woorden --

  7. #7
    Giga Honourable Senior Member
    Verenigingslid

    Geregistreerd
    12 juni 2008
    PHP Code:
    1
    
    =500*((LEFT(A42;1)="v")*(B42>10^5)+(LEFT(A42;1)="W")*(B42>75000))
    VBA voor smarties
    VBA is een taal die je moet leren met een grammatica- en een woordenboek.

    http://www.helpmij.nl/forum/announcement.php?f=5
    Plaats svp geen bestanden op andere sites; nadat het bestand daar verwijderd is wordt een forumdraad onbegrijpelijk voor anderen.

  8. #8
    Junior Member
    Geregistreerd
    2 december 2019
    Hallo,

    bedankt voor de vele reacties en de uiteindelijke oplossing.
    Sorry dat ik een afbeelding van de tabel doorgestuurd heb ipv de file zelf, ik ben het niet gewoon van dingen te vragen op fora en had niet direct door hoe ik mijn file kon uploaden.
    DANK U DANK U

  9. #9
    Giga Honourable Senior Member
    Geregistreerd
    18 juli 2008
    Code:
    =500*(C2>ZOEKEN(WAAR;(LINKS(B2;1)={"v";"W"});({100000;75000})))
    ____________
    Met vriendelijke groet,
    Harry

    Lag nooit om de keuzes van dien vraauw, bist ter zulf aine van....
    (Grunnegs-Gronings)

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren