Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 15 van 15

Onderwerp: doorvoeren

  1. #1
    Vraag is niet opgelost

    doorvoeren

    hallo
    normaal gesproken kom ik er met exel en wat kunst en vliegwerk wel uit
    simpele dingen voor mij voldoende
    maar nu zit me toch iets dwars
    ik wil de onderstaande formule doortrekken
    maar dat gaat me niet lukken
    mijn vraag is dan ook
    kun je zoiets wel doortrekken

    bvd willem



    =ALS(SOM(zonnepanelen!U29:U35)=0;"";SOM(zonnepanelen!U29:U35))
    =ALS(SOM(zonnepanelen!V36:V42)=0;"";SOM(zonnepanelen!V36:V42))
    =ALS(SOM(zonnepanelen!V43:V49)=0;"";SOM(zonnepanelen!V43:V49))

  2. #2
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 April 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Bereiken vastzetten met $-tekens:
    Code:
    =ALS(SOM(zonnepanelen!$U$29:$U$35)=0;"";SOM(zonnepanelen!$U$29:$U$35))
    =ALS(SOM(zonnepanelen!$V$36:$V$42)=0;"";SOM(zonnepanelen!$V$36:$V$42))
    =ALS(SOM(zonnepanelen!$V$43:$V$49)=0;"";SOM(zonnepanelen!$V$43:$V$49))
    Als je daarna alle drie de cellen met formules tegelijk selecteert kun je ze gewoon doortrekken naar onder. Excel herhaalt dan automatisch de formules.

    Als je iets anders bedoelt, bijvoorbeeld omdat de bereiken anders moeten worden, is het advies: plaats s.v.p. even een (Excel) voorbeeldje.
    Laatst aangepast door AlexCEL : 25 March 2020 om 13:09
    -- een (excel) voorbeeldbestandje zegt meer dan 1000 woorden --

  3. #3
    bedankt ga ik proberen

  4. #4
    Quote Origineel gepost door AlexCEL Bekijk Bericht
    Bereiken vastzetten met $-tekens:
    Code:
    =ALS(SOM(zonnepanelen!$U$29:$U$35)=0;"";SOM(zonnepanelen!$U$29:$U$35))
    =ALS(SOM(zonnepanelen!$V$36:$V$42)=0;"";SOM(zonnepanelen!$V$36:$V$42))
    =ALS(SOM(zonnepanelen!$V$43:$V$49)=0;"";SOM(zonnepanelen!$V$43:$V$49))
    Als je daarna alle drie de cellen met formules tegelijk selecteert kun je ze gewoon doortrekken naar onder. Excel herhaalt dan automatisch de formules.

    Als je iets anders bedoelt, bijvoorbeeld omdat de bereiken anders moeten worden, is het advies: plaats s.v.p. even een (Excel) voorbeeldje.
    hallo

    de bedoeling is niet dat ie het herhaald maar dat die V29-V35 / V36-V42 / V43-V49 volgende zou moeten worden V50-V56 /V57-V63 /enzovoorts
    ik kijk of ik een voorbeeld ik elkaar kan zetten

  5. #5
    Senior Member
    Geregistreerd
    27 February 2019
    Dit is een oplossing. Daarna de hulpkolommen verbergen.
    Bijgevoegde bestanden Bijgevoegde bestanden

  6. #6
    hierbij mijn voorbeeld
    Bijgevoegde bestanden Bijgevoegde bestanden

  7. #7
    en dit zou ik dan door moeten kunnen voeren

    willem

  8. #8
    Senior Member
    Geregistreerd
    27 February 2019
    Ja zorg wel dat de hulpkolommen ook ver genoeg doorgevoerd zijn

  9. #9
    Senior Member
    Geregistreerd
    27 February 2019
    In jouw voorbeeldje
    Bijgevoegde bestanden Bijgevoegde bestanden

  10. #10
    hallo

    perfect

    ik ben maar een simpele timmerman/meubelmaker ik ben dit al een paar maanden aan het proberen
    op mijn klungelige manier
    tot nu toe iedere keer alles met de hand ingevoerd avonden bezig geweest
    en nu is het in een paar minuten opgelost

    heel veel dank

  11. #11
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 April 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Zelf proberen goed, maar je mag best een vraag stellen hoor!
    Excel heeft meestal wel een slimme oplossing voor repeterende taken.

    Hier nog een optie voor je voorbeeld om te bestuderen, zonder gebruik hulpkolom:
    Code:
    =ALS.FOUT(1/(1/SOM(VERSCHUIVING(Blad1!$A$1;(RIJ(A1)-1)*7;;7)));"")
    Laatst aangepast door AlexCEL : 25 March 2020 om 15:11
    -- een (excel) voorbeeldbestandje zegt meer dan 1000 woorden --

  12. #12
    Senior Member
    Geregistreerd
    27 February 2019
    Hi Alex, mooie formule. Uit nieuwsgierigheid, wat doet die 1/(1/...) in deze formule? Of wat is daarvan de functie over het algemeen.

  13. #13
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 April 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Dat is om een foutmelding te genereren als de uitkomst 0 is. 1/(1/0) = fout, en dan maakt de ALS.FOUT er mooi "" van, zoals gewenst. Als het geen 0 is dan krijg je gewoon de originele waarde terug. Deze aanpak kan alleen als de uitkomst een getal is trouwens.
    -- een (excel) voorbeeldbestandje zegt meer dan 1000 woorden --

  14. #14
    Senior Member
    Geregistreerd
    27 February 2019
    Begrepen! Bedankt

  15. #15
    hoi alex

    ik begrijp van de hele formule niks
    maar ik heb het in mijn bestand werkend gekregen

    nogmaals bedankt en JVeer ook
    die van jou werkt ook maar die van alex is nog makkelijker sorry

    ik wou dat ik vroeger beter opgelet had op school

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren