Helpmij.nl
Helpmij.nl
Helpmij.nl
Steun Helpmij.nl! Klik hier     Computerprobleem? Klik hier!

Quote

Weergeven resultaten 1 tot 5 van 5

Onderwerp: Verticaal zoeken

  1. #1
    Vraag is niet opgelost

    Verticaal zoeken

    Beste,

    Ik heb een excel lijst met binnenkomende goederen en een lijst met orders.
    Nu wil ik achter iedere regel bij de binnenkomende goederen gelijk zetten voor wie het is.
    Alleen met verticaal zoeken lukt het niet.
    Ik heb een redelijke kennis van Excel maar hier kom ik niet uit!

    Kan iemand mij helpen?
    Bijgevoegde bestanden Bijgevoegde bestanden

  2. #2
    Tera Honourable Senior Member
    Verenigingslid
    OctaFish's avatar
    Geregistreerd
    6 February 2009
    Locatie
    Rotterdam
    Afstand tot server
    ±151 km
    Toch is je probleem simpel: in kolom A eindigt elk artikelnummer met een spatie, en die zit niet in je Orders tabel. Dus vindt-ie 'm niet. Haal in A2 de spatie weg, en je formule werkt prima.
    Gebruik de QUOTE knop alleen als je iets wit citeren.
    Op deze pagina kun je zien hoe je met TAGS werkt.

  3. #3
    Tera Honourable Senior Member
    Verenigingslid
    OctaFish's avatar
    Geregistreerd
    6 February 2009
    Locatie
    Rotterdam
    Afstand tot server
    ±151 km
    Ik zou 'm nog wel aanpassen, want je kunt hem zo nog niet doorkopiëren. Allereerst doordat de range niet vast staat, en verder ontbreken er nogal wat artikelen, dus dan krijg je een foutmelding. Ik zou 'm zo maken:
    PHP Code:
    1
    
    =ALS.FOUT(VERT.ZOEKEN(Blad1!A2;Orders!$A$1:$K$437;11;ONWAAR);"")
    Gebruik de QUOTE knop alleen als je iets wit citeren.
    Op deze pagina kun je zien hoe je met TAGS werkt.

  4. #4
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 April 2014
    Locatie
    Groningen
    Afstand tot server
    ±117 km
    Als je spaties niet weg wilt halen om wat voor reden ook:
    Code:
    =ALS.FOUT(VERT.ZOEKEN(SPATIES.WISSEN(A2);Orders!$A$1:$K$437;11;0);"")
    Edit:
    Voor veel artikelen zijn er verschillende documenten te vinden. Bijvoorbeeld voor artikel "247950-1028-10" zijn er al 4 documentnummers te vinden: V01117, V01225, V01229 en V01235. Met VERT.ZOEKEN krijg je alleen de eerste overeenkomst. Hoe moet hiermee omgegaan worden?
    Laatst aangepast door AlexCEL : 26 March 2020 om 13:53
    -- een (excel) voorbeeldbestandje zegt meer dan 1000 woorden --

  5. #5
    Senior Member
    Verenigingslid
    Piet Bom's avatar
    Geregistreerd
    13 November 2010
    Locatie
    Fine Earth
    Volgens mij is dat een mooie casus om met PowerPivot aan te pakken.
    Dan zou je wel van die lastige trailing spaties af moeten.
    Met vriendelijke groeten / Kind regards / Mit freundlichen Grüßen / Meilleurs souvenirs / Venlig hilsen / Cordiali saluti / Atentos saludos / Considerações Amáveis / Saygilarimla / مع أطيپ التحيات,
    Piet Bom

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren