Helpmij.nl
Helpmij.nl
Helpmij.nl

Quote

Weergeven resultaten 1 tot 19 van 19

Onderwerp: vert zoeken met een zoekwaarde die die samengesteld is

  1. #1
    Senior Member
    Verenigingslid
    Friend's avatar
    Geregistreerd
    31 januari 2009
    Vraag is opgelost

    vert zoeken met een zoekwaarde die die samengesteld is

    Beste forummers,

    In de bijlage een eenvoudige opzet van vert zoeken waarin de zoekwaarde een samenstelling is van de waarde die gezocht moet worden in twee kolommen op een ander werkblad.

    Is dit mogelijk?

    Friend
    Bijgevoegde bestanden Bijgevoegde bestanden
    Beter vandaag gemaakt dan tot morgen gewacht

  2. #2
    doe het dan zo?
    Bijgevoegde bestanden Bijgevoegde bestanden

  3. #3
    Giga Honourable Senior Member
    Geregistreerd
    2 maart 2013
    PHP Code:
    1
    
    =INDEX(naw!$B$2:$B$4;MATCH(B2;LEFT(naw!$A$2:$A$4;6)&naw!$B$2:$B$4;0))&""
    Laatst aangepast door VenA : 17 september 2020 om 18:54
    Je kan een paard naar het water leiden, maar je kan het niet dwingen te drinken.

  4. #4
    Senior Member
    Verenigingslid
    Friend's avatar
    Geregistreerd
    31 januari 2009
    Emields,

    Hartelijk dank voor je reactie

    Ik denk niet dat dit helemaal voor mij de oplossing geeft.

    Door de code geeft hij altijd de 7e positie. Terwijl de code variabel kan zijn in lengte.

    Voor de duidelijkheid de code is de postcode + huisnr + de 1e voorletter van de bewoner.

    Deze gebruik ik dan met vert.zoeken op het werkblad naw om de adresgegevens op te zoeken.

    Daar staat de code in de tabel die regelmatig overschreven wordt als postcode + huisnr.

    Ik voeg de voorletter van de persoon daaraan toe om als er meerdere mensen op het zelfde adres zitten ik dit per persoon kan kiezen.

    Even het bestand opnieuw geplaatst met jouw code.

    Friend
    Bijgevoegde bestanden Bijgevoegde bestanden
    Beter vandaag gemaakt dan tot morgen gewacht

  5. #5
    Senior Member
    Verenigingslid
    Friend's avatar
    Geregistreerd
    31 januari 2009
    JVeer,

    Hartelijk dank voor je reactie

    Het is voor mij even niet helemaal duidelijk waar ik jouw code plaats.

    Ik heb nu dit : Klik op afbeelding voor grotere versie

Naam:  plcode.JPG
Bekeken: 10
Grootte:  64,2 KB

    Maar ik zie geen "beweging"

    Wat doe ik fout?

    Friend
    Beter vandaag gemaakt dan tot morgen gewacht

  6. #6
    Senior Member
    Verenigingslid
    Friend's avatar
    Geregistreerd
    31 januari 2009
    VenA,

    Hartelijk dank voor je reactie

    In de bijlage heb ik je code ingevuld.

    Maar zal ook hier iets verkeerd doen.

    Zou je er nog even naar willen kijken?

    Friend
    Bijgevoegde bestanden Bijgevoegde bestanden
    Beter vandaag gemaakt dan tot morgen gewacht

  7. #7
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Als je een NEDERLANDS-talige Excelversie gebruikt, zou het dan handig zijn om aangedragen ENGELS-talige formules (zoals in #4) even in het NEDERLANDS te vertalen? (tip: https://nl.excel-translator.de/translator/)

    In bijlage een poging mijnerzijds. De opzet van je tabel en de gewenste uitkomst maakt het wel complex qua oplossing met heel veel INDEX functies achter elkaar.

    Let op: het zijn ook matrixfuncties, d.w.z. afsluiten met Control+Shift+Enter als je geen Excel 365 gebruikt.
    Bijgevoegde bestanden Bijgevoegde bestanden
    Laatst aangepast door AlexCEL : 17 september 2020 om 21:13
    -- een (excel) voorbeeldbestandje zegt meer dan 1000 woorden --

  8. #8
    Mega Senior JVeer's avatar
    Geregistreerd
    27 februari 2019
    Aan deze heb je denkik dan ook al genoeg(office 365 vereist)

    Code:
    =ALS.FOUT(TEKST.COMBINEREN(", ";WAAR;TRANSPONEREN(BEGINLETTERS(INDEX(naw!$B$2:$F$100;VERGELIJKEN(B2;naw!$A$2:$A$100&naw!$B$2:$B$100;0);RIJ($1:$5))&"")));"")
    Laatst aangepast door JVeer : 17 september 2020 om 21:43
    Gr,
    JV

  9. #9
    Senior Member
    Verenigingslid
    Friend's avatar
    Geregistreerd
    31 januari 2009
    Alexcel,

    Hartelijk dank voor je reactie

    Dat is een lange, lange code maar doet precies wat ik zoek

    Nu ga ik nog een kolom tussenvoegen voor TV.

    Goed huiswerk om de code te proberen begrijpen.

    Nogmaals dank voor je hulp,

    Friend
    Beter vandaag gemaakt dan tot morgen gewacht

  10. #10
    Senior Member
    Verenigingslid
    Friend's avatar
    Geregistreerd
    31 januari 2009
    JVeer,

    Hartelijk dank voor je respons

    Dat werkt ook fantastisch

    Is het gewoon anders schrijven/benadering/manier om tot hetzelfde resultaat te komen?

    Heel veel dank.

    Friend
    Beter vandaag gemaakt dan tot morgen gewacht

  11. #11
    Mega Senior JVeer's avatar
    Geregistreerd
    27 februari 2019
    Dat is een net wat andere manier waardoor alles in 1 klap meekomt. De matrix van de INDEX functie in combinatie met de [kolom] "RIJ(1:5)" van de VERGELIJKEN functie doet de truc.
    Wel zijn de komma's net iets anders geplaatst

    De "RIJ(1:5)" verwijst naar de kolommen die je terug wil krijgen. Dus de naam en adres gegevens.

    Edit: Zou nog wat korter kunnen

    Code:
    =ALS.FOUT(TEKST.COMBINEREN(", ";WAAR;BEGINLETTERS(INDEX(naw!$B$2:$F$100;VERGELIJKEN(B2;naw!$A$2:$A$100&naw!$B$2:$B$100;0);KOLOM($A1:$E1))&""));"")
    Laatst aangepast door JVeer : 17 september 2020 om 22:25
    Gr,
    JV

  12. #12
    Senior Member
    Verenigingslid
    Friend's avatar
    Geregistreerd
    31 januari 2009
    JVeer,

    Hartelijk dank voor de uitleg.

    Een vraagje. De code plaatst na een kolom waarde een komma. Die heb ik er nu even uitgehaald.

    Code:
    =ALS.FOUT(TEKST.COMBINEREN(" ";WAAR;TRANSPONEREN(BEGINLETTERS(INDEX(naw!$B$2:$G$100;VERGELIJKEN(B2;naw!$A$2:$A$100&naw!$B$2:$B$100;0);RIJ($1:$6))&"")));"")
    Dan krijg ik dit: Ab De Klein Appelweg 13 1063 Aa Tellingen

    Maar is het ook mogelijk om de komma iets gerichter te plaatsen?

    Ab De Klein, Appelweg 13, 1063 Aa Tellingen

    Friend
    Beter vandaag gemaakt dan tot morgen gewacht

  13. #13
    Mega Senior JVeer's avatar
    Geregistreerd
    27 februari 2019
    Code:
    =ALS.FOUT(TEKST.COMBINEREN(ALS(KOLOM($A$1:$E$1)>1;", ";" ");WAAR;BEGINLETTERS(INDEX(naw!$B$2:$F$100;VERGELIJKEN(B2;naw!$A$2:$A$100&naw!$B$2:$B$100;0);KOLOM($A1:$E1))&""));"")
    Zoiets.

    De laatste komma krijg ik nog even niet weg op een korte manier. Daar kan ik morgen nog even naar kijken

    Code:
    =ALS.FOUT(TEKST.COMBINEREN(ALS(KOLOM($A$1:$E$1)>1;", ";" ");WAAR;BEGINLETTERS(INDEX(naw!$B$2:$F$100;VERGELIJKEN(B2;naw!$A$2:$A$100&naw!$B$2:$B$100;0);KOLOM($A1:$D1))&""));"")&" "&INDEX(naw!$B$2:$F$100;VERGELIJKEN(B2;naw!$A$2:$A$100&naw!$B$2:$B$100;0);5)
    Laatst aangepast door JVeer : 17 september 2020 om 22:48
    Gr,
    JV

  14. #14
    Giga Senior AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Zoiets dan?
    Code:
    =ALS.FOUT(SUBSTITUEREN(SUBSTITUEREN(TEKST.COMBINEREN(", ";WAAR;TRANSPONEREN(BEGINLETTERS(INDEX(naw!$B$2:$G$100;VERGELIJKEN(B2;naw!$A$2:$A$100&naw!$B$2:$B$100;0);RIJ($1:$6))&"")));", ";". ";1);", ";" ";3);"")
    Excel 365 maakt de oplossing wel wat makkelijker...
    -- een (excel) voorbeeldbestandje zegt meer dan 1000 woorden --

  15. #15
    Mega Senior JVeer's avatar
    Geregistreerd
    27 februari 2019
    Toch nog even verder gekeken
    En inderdaad. Blij met office 365

    Code:
    =ALS.FOUT(TEKST.COMBINEREN(ALS((RIJ($1:$5)>1)*(RIJ($1:$5)<4)>0;", ";" ");WAAR;BEGINLETTERS(INDEX(naw!$B$2:$F$100;VERGELIJKEN(B2;naw!$A$2:$A$100&naw!$B$2:$B$100;0);KOLOM($A1:$E1))&""));"")
    Laatst aangepast door JVeer : 17 september 2020 om 23:11
    Gr,
    JV

  16. #16
    en hier nog 2 oplossingen met vba.
    Bijgevoegde bestanden Bijgevoegde bestanden

  17. #17
    Senior Member
    Verenigingslid
    Friend's avatar
    Geregistreerd
    31 januari 2009
    JVeer,

    Hartelijk dank voor de aanvulling

    Mooi

    Friend
    Beter vandaag gemaakt dan tot morgen gewacht

  18. #18
    Senior Member
    Verenigingslid
    Friend's avatar
    Geregistreerd
    31 januari 2009
    Emields,

    Heel hartelijk dank voor je extra aanreiking in VBA

    Dat ziet er ook mooi uit

    Kan ik ook prima mee verder dus dat wordt kiezen

    Thanks

    Friend
    Beter vandaag gemaakt dan tot morgen gewacht

  19. #19
    Senior Member
    Verenigingslid
    Friend's avatar
    Geregistreerd
    31 januari 2009
    AlexCel,

    Ook dank voor de extra code

    Bijzonder hoe jullie dit allemaal schrijven.

    Friend
    Beter vandaag gemaakt dan tot morgen gewacht

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl

Regels
Help

Helpmij.nl en business

Partners
Sponsoren