Helpmij.nl
Helpmij.nl
Helpmij.nl

Quote

Weergeven resultaten 1 tot 6 van 6

Onderwerp: Als en / of

  1. #1
    Vraag is niet opgelost

    Als en / of

    Goedemiddag,

    Ik kom niet helemaal weg met een formule. Daarom in bijlage een voorbeeld bestand.

    CEL E6 moet een getal of NA projecteren wanneer:

    ALS CEL C1 = Gelijk aan TES en ALS CEL A6 = gelijk aan N en CEL C2 = Gelijk aan ja en CEL F2 = gelijk aan of lager als 0 dan moet CEL E6 "NA" projecteren
    OF WANNEER
    ALS CEL C1 = Gelijk aan KON en ALS CEL B6 = gelijk aan N en CEL C2 = Gelijk aan ja en CEL D2 = gelijk aan of lager als 0 dan moet CEL E6 "NA" projecteren

    Ik kom niet verder nu als:
    Code:
    =ALS(EN(C1="KON";B6="N");"NA";ALS(EN($E$2="JA";$F$2<=0);"NA";AFRONDEN.NAAR.BOVEN(D6;2)))
    Ik weet dat ENOF niet kan, maar praktisch is dit wat ik probeer te doen / krijgen
    Code:
    =ALS(ENOF(C1="KON";B6="N" C1="TES";A6="N");"NA";ALS(EN($E$2="JA";$F$2<=0);"NA";AFRONDEN.NAAR.BOVEN(D6;2)))
    Hoe krijg ik dit voor elkaar?
    Bijgevoegde bestanden Bijgevoegde bestanden

  2. #2
    Giga Honourable Senior Member
    Geregistreerd
    2 maart 2013
    dan zal het zoiets worden

    Code:
    =AND(OR(AND(C1="TES";A6="N");AND(C1="KON";B6="N"));C2="ja";F2<=0)
    Je kan een paard naar het water leiden, maar je kan het niet dwingen te drinken.

  3. #3
    Mega Honourable Senior Member AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    CEL E6 moet een getal of NA projecteren wanneer:
    ALS CEL C1 = Gelijk aan TES en ALS CEL A6 = gelijk aan N en CEL C2 = Gelijk aan ja en CEL F2 = gelijk aan of lager als 0 dan moet CEL E6 "NA" projecteren
    OF WANNEER
    ALS CEL C1 = Gelijk aan KON en ALS CEL B6 = gelijk aan N en CEL C2 = Gelijk aan ja en CEL D2 = gelijk aan of lager als 0 dan moet CEL E6 "NA" projecteren
    Samengevat kom ik dan hierop:
    ALS (C1=TES)+(A6= N)+(C2=ja)+(F2<=0) of (C1=KON)+(B6=N)+(C2=ja)+(D2<= 0) dan NA anders D6 naar boven afronden.

    In Excel-taal:
    Code:
    =ALS(OF(EN(C1="TES";A6="N";C2="ja";F2<=0);EN(C1="KON";B6="N";C2="ja";D2<=0));"NA";AFRONDEN.NAAR.BOVEN(D6;2))
    Laatst aangepast door AlexCEL : 21 juli 2021 om 14:13
    -- een (excel) voorbeeldbestandje zegt meer dan 1000 woorden --

  4. #4
    Quote Origineel gepost door AlexCEL Bekijk Bericht
    Samengevat kom ik dan hierop:
    ALS (C1=TES)+(A6= N)+(C2=ja)+(F2<=0) of (C1=KON)+(B6=N)+(C2=ja)+(D2<= 0) dan NA anders D6 naar boven afronden.

    In Excel-taal:
    Code:
    =ALS(OF(EN(C1="TES";A6="N";C2="ja";F2<=0);EN(C1="KON";B6="N";C2="ja";D2<=0));"NA";AFRONDEN.NAAR.BOVEN(D6;2))
    Dankje, Wat hij niet doet is Wanneer ik C1 op TES heb staan en A6 op N heb staan dat hij dan NA aangeeft. Hij blijft dan E6 gewoon het getal laten zien ipv NA

  5. #5
    Mega Honourable Senior Member AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Je moet je voorwaarden dan nog maar eens goed neerzetten. Dit stond niet in je verhaal, daar moet alles waar zijn. Of tenminste: zo lees ik het.

    Dus: welke uitkomsten onder welke voorwaarden. Ik gok dat je ergens een OF vergeten bent...

    Misschien zo?
    Code:
    =ALS(OF(EN(C1="KON";B6="N");EN(C1="TES";A6="N");EN(E2="JA";F2<=0));"NA";AFRONDEN.NAAR.BOVEN(D6;2))
    Laatst aangepast door AlexCEL : 21 juli 2021 om 15:22
    -- een (excel) voorbeeldbestandje zegt meer dan 1000 woorden --

  6. #6
    Quote Origineel gepost door AlexCEL Bekijk Bericht
    Je moet je voorwaarden dan nog maar eens goed neerzetten. Dit stond niet in je verhaal, daar moet alles waar zijn. Of tenminste: zo lees ik het.

    Dus: welke uitkomsten onder welke voorwaarden. Ik gok dat je ergens een OF vergeten bent...

    Misschien zo?
    Code:
    =ALS(OF(EN(C1="KON";B6="N");EN(C1="TES";A6="N");EN(E2="JA";F2<=0));"NA";AFRONDEN.NAAR.BOVEN(D6;2))
    Deze werkt perfect! Dankje!

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl

Regels
Help

Helpmij.nl en business

Partners
Sponsoren