Helpmij.nl
Helpmij.nl
Helpmij.nl

Quote

Weergeven resultaten 1 tot 6 van 6

Onderwerp: aantal.als met behoud van de huidige rij - autocorrectie excel uitzetten

  1. #1
    Vraag is opgelost

    aantal.als met behoud van de huidige rij - autocorrectie excel uitzetten

    Hallo

    Ik gebruik de formule: =AANTAL.ALS($B$2:$B24;B24) om te berekenen hoeveel keer de cel op die lijn in B-kolom voorkomt. Hij mag enkel rekening houden met het voorkomen van dat getal in de rijen voorafgaand.

    Excel corrigeert vaak automatisch die formule naar een groter bereik. Echter dit mag niet gebeuren.
    ik voegde deze formule toe in een tabel, zodat elke nieuwe lijn deze formule ook heeft.
    ik heb reeds meerdere malen de automatische correctie terug geannuleerd, maar toch blijft excel dit opnieuw doen.
    Idee hoe ik dit kan oplossen?

    Alvast bedankt
    Bijgevoegde bestanden Bijgevoegde bestanden
    Laatst aangepast door JokeTanghe : 27 juli 2021 om 15:14

  2. #2
    Mega Senior
    Verenigingslid

    Geregistreerd
    27 februari 2016
    Met een voorbeeldbestandje wordt je sneller geholpen.
    Geef duidelijk aan wat je als resultaat verwacht. Voor mij is dat nu nog onduidelijk.
    Met vriendelijke groet,
    Albert

  3. #3
    Mega Honourable Senior Member AlexCEL's avatar
    Geregistreerd
    3 april 2014
    Locatie
    Groningen
    Leuk al die koppelingen. Je hebt ook een cruciale opmerking vergeten:
    Geef duidelijk aan wat je als resultaat verwacht.
    Gaat het om kolom L? Deze lijkt mij correct... wat gaat hier niet goed?
    Laatst aangepast door AlexCEL : 27 juli 2021 om 16:43
    -- een (excel) voorbeeldbestandje zegt meer dan 1000 woorden --

  4. #4
    Hallo,
    ik wil dat in kolom L de formule niet wordt aangepast.
    Kolom L moet tellen hoeveel keer de code in kolom B voorkomt, en dit op het moment dat je die rij invult. De waarde mag nadien niet meer wijzigen in die rij.
    vb in rij 30 voer ik de vorming met code o21 toe. in kolom L moet hij tellen hoeveel keer de code o21 voorkomt in de rijen tem rij 30. ( want dit bepaalt of hij tarief in kolom N of O moet gebruiken)

    Nu past excel vaak ( niet altijd) de formule in kolom L aan zodra je rijen eronder toevoegt (ook al is het een andere code dat toegevoegd wordt).

  5. #5
    Giga Honourable Senior Member
    Geregistreerd
    18 juli 2008
    Probeer het zo eens.

    Code:
    =AANTAL.ALS(B$2:Tabel1[[#Deze rij];[Kolom1]];Tabel1[[#Deze rij];[Kolom1]])
    Laatst aangepast door HSV : 27 juli 2021 om 17:28
    ____________
    Met vriendelijke groet,
    Harry

    Lag nooit om de keuzes van dien vraauw, bist ter zulf aine van....
    (Grunnegs-Gronings)

  6. #6
    Hallo HSV

    Het lukt helemaal.
    Eerst lukte het niet, hij gaf een foutmelding in mijn eigen bestand. na het plaatsen van jouw formule in "voorbeeldbestand" herleidde excel jouw formule automatisch naar deze:
    =AANTAL.ALS(B$2:[@kolom1];[kolom1]) en nu lukt het wel.
    Het lost zelfs ook mijn probleem op, dat hij de historiek niet meer bijhoudt. vb je voerde ooit een regel in, maar verwijderde die... dan bleef hij toch verder tellen in de rijen...
    Heel erg bedankt!

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl

Regels
Help

Helpmij.nl en business

Partners
Sponsoren