Helpmij.nl
Helpmij.nl
Helpmij.nl

Quote

Weergeven resultaten 1 tot 5 van 5

Onderwerp: omzetten formule naar vba

  1. #1
    Senior Member
    Geregistreerd
    25 april 2014
    Vraag is opgelost

    omzetten formule naar vba

    beste helpers
    ik had heel graag onderstaande code werkend in vba
    kan iemand mij daarmee helpen
    Code:
    =ALS.FOUT(TEKST.COMBINEREN(";";WAAR;FILTER(C2:C56;B2:B56="x"));"-")
    Ben er al even mee bezig maar wil niet lukken
    dit heb ik :
    Code:
    Range("g13") = WorksheetFunction.TextJoin(";", True, Filter(Range("c2:c56"), Range("b2:b56"), True, "x"))
    bvd
    Don
    Laatst aangepast door don42 : 26 juni 2022 om 12:14

  2. #2
    Giga Honourable Senior Member
    Verenigingslid
    snb's avatar
    Geregistreerd
    12 juni 2008
    Gebruik in Excel Excel funkties/formules; gebruik in VBA VBA-methoden (arrays, loops, etc.); en plaats in fora voorbeeldbestanden.
    VBA voor smarties
    VBA is een taal die je moet leren met een grammatica- en een woordenboek.

    http://www.helpmij.nl/forum/announcement.php?f=5
    Plaats svp geen bestanden op andere sites; nadat het bestand daar verwijderd is wordt een forumdraad onbegrijpelijk voor anderen.

  3. #3
    Giga Senior JEC.'s avatar
    Geregistreerd
    27 februari 2019
    Dus:

    Code:
    Sub jec()
     Dim ar, a, i As Long
     ar = Range("B2:C56")
    
     For i = 1 To UBound(ar)
       If ar(i, 1) = "x" Then a = a & ";" & ar(i, 2)
     Next
     
     If Len(a) = 0 Then a = " -"
     Range("G13") = Mid(a, 2)
    End Sub
    Laatst aangepast door JEC. : 26 juni 2022 om 13:15
    Gr,
    JV

  4. #4
    Giga Senior JEC.'s avatar
    Geregistreerd
    27 februari 2019
    Code:
    Sub jecc()
     With Range("B2:B56")
       Range("G13") = Join(Filter(Evaluate("transpose(if(" & .Address & "=""x"", " & .Offset(, 1).Address & "))"), False, 0), ";")
     End With
    End Sub
    of

    Code:
    Sub jec()
    [g13] = [iferror(textjoin(";",,filter(C2:C56,B2:B56="x")),"-")]
    End Sub
    Laatst aangepast door JEC. : 26 juni 2022 om 13:26
    Gr,
    JV

  5. #5
    Senior Member
    Geregistreerd
    25 april 2014
    Bedankt voor jullie hulp 👍

Berichtenregels

  • U mag geen nieuwe vragen starten.
  • U mag niet reageren op berichten.
  • U mag geen bijlagen versturen.
  • U mag uw berichten niet bewerken.
  •  
Helpmij.nl
Helpmij.nl

Helpmij.nl en business

Partners
Sponsoren