• Privacywetgeving
    Het is bij Helpmij.nl niet toegestaan om persoonsgegevens in een voorbeeld te plaatsen. Alle voorbeelden die persoonsgegevens bevatten zullen zonder opgaaf van reden verwijderd worden. In de vraag zal specifiek vermeld moeten worden dat het om fictieve namen gaat.

Opgelost N#B bij verticaal zoeken in Excel

Dit topic is als opgelost gemarkeerd

Hans290875

Gebruiker
Lid geworden
13 apr 2013
Berichten
38
In bijgaand Excel model probeer ik een verticaal zoeken formule te maken.
Maar het resultaat is steeds weer N#B.
De bedoeling is dat van de in kolom C genoemde landen de omzet uit kolom M vermelde omzet wordt genoteerd in kolom E.
Het zoekgebied is kolom I8 t/m T63.
Wat doe ik fout of zie ik over het hoofd.

Met vriendelijke groet,
Hans
 

Bijlagen

  • Boor 2024.xls
    1,6 MB · Weergaven: 7
Wat je "fout" doet is het bereik van de zoektabel. VERT.ZOEKEN zoekt in de eerste kolom naar een gewenste waarde en geeft dan op de eerste gevonden rij de gewenste kolom terug. Bij jouw bereik bevat de eerste kolom datums, en geen landen waarop gezocht moet worden.

Oplossing:
Code:
=ALS.FOUT(VERT.ZOEKEN(C28;$K$8:$T$63;3;0);"?")
Heel veel landen komen niet voor... dus je krijgt veel vraagtekens.
 
Laatst bewerkt:
Met index vergelijken, er komen geen vergelijkingen in voor volgens mij.
Kijk eens naar de landen, is Austria geen Australia of klopt dat.
Hij kijkt naar datum en land.
Welke versie van excel heb je eigenlijk?
 

Bijlagen

  • Boor 2024 JV.xls
    1,6 MB · Weergaven: 1
Beste Johan.
De Excel versie is van MIcrosoft 365.
Ik heb de boel wat aangepast met sortering van de landen op alfabet en vervolgens met subtotalen de omzet per land getotaliseerd, maar nu werkt de formule niet meer.
Dus ik doe weer iets fout.
Maar wat?
Groet
Hans
 

Bijlagen

  • Boor 2024.xls
    1,6 MB · Weergaven: 8
Mag Alex ook meedenken?

Hint: is "total" hetzelfde als "totaal"?
 
@Hans290875
Je maakt er een rommeltje van.
De namen in kolom C moeten hetzelfde zijn als in Kolom K.
De datums zijn er niet meer bij de totalen dus daar kun je dan niets mee.
Er staat soms meerdere keren United States of andere zonder datum dus kun je daar niet op zoeken.
Jouw bestand is een bestand met macro's dus moet in de 365 liever als .xlsm of .xlsb worden opgeslagen.
Kijk ook naar de opmerkingen van @AlexCEL, dat zijn de super specialisten op het gebied van formules en uitkomsten.
 
Beste Johan & ALex
Met jullie input heb ik het verticaal zoeken toch 'aan de praat' gekregen.
Omdat het zoeken op naam is en niet op datum, is het ontbreken van een datum niet belangrijk.
Daar wordt verder toch niets meegedaan.
Hartelijk dank voor jullie meedenken.
Groet Hans
 
Terug
Bovenaan Onderaan