• Privacywetgeving
    Het is bij Helpmij.nl niet toegestaan om persoonsgegevens in een voorbeeld te plaatsen. Alle voorbeelden die persoonsgegevens bevatten zullen zonder opgaaf van reden verwijderd worden. In de vraag zal specifiek vermeld moeten worden dat het om fictieve namen gaat.

functie-probleem

Status
Niet open voor verdere reacties.

e.mussche

Gebruiker
Lid geworden
1 jan 2003
Berichten
65
Wie kan mij helpen voor het maken van de volgende functie.
Ik gebruik deze om mijn overuren te kunnen berekenen.
De volgende gegevens gebruik ik :
eindtijd - begintijd
Overuren beginnen na 16.45
Overuren tot 20.00 uur is x 125%
Overuren na 20.00 uur is x 150%

Welke functie ?
Wie helpt mij ?
Alvast bedankt !
 
stel:
A1 = beginuur
B1 = einduur

uren tot 16:45
=MIN("16:45";B1)-A1

uren tussen 16:45 en 20:00
=ALS(B1<=TIJD(16;45;0);"";MIN("20:00";B1)-"16:45")

uren na 20:00
=ALS(B1<=TIJD(20;0;0);"";B1-"20:00")

Als de werkuren ook over middernacht kunnen lopen wordt de berekening een stuk ingewikkelder. Een voorbeeld hiervan kan je zien in dit document: werkrooster.xls
 
optellen

Kun je beide functies ook optellen bij elkaar in één functie ?
alvast bedankt !
 
Gewoon de formules tegen elkaar plakken:

=ALS(B1<=TIJD(16;45;0);"";MIN("20:00";B1)-"16:45")*1,25+ALS(B1<=TIJD(20;0;0);"";B1-"20:00")*1,5
 
Het plakken lukt inderdaad, maar het probleem is toch nog iets complexer.
Want als il vam 22.00 tot 22.30 werk of van 17.00 tot 18.00 werk werkt de formule niet.
Een ding is wel iets simpeler: de hele dag tot 20.00 uur krijgen we toeslag van 125 %.
Help je nog een keer ?
Bedankt !!
 
Beste

In bijlage een bestandje dat de overuren berekent voor 3 renumeratieperiodes/dag. In de oranje gekleurde cellen mogen gegevens ingevoerd worden, alle andere cellen worden berekend.

Veel succes ermee en hopelijk doet het wat je wilt dat het doet.

BBB
 

Bijlagen

  • overuren.zip
    2,3 KB · Weergaven: 51
Status
Niet open voor verdere reacties.
Steun Ons

Nieuwste berichten

Terug
Bovenaan Onderaan