beveiliging tegen naamsverandering werkt omgekeerd

Status
Niet open voor verdere reacties.

mcfreak

Gebruiker
Lid geworden
21 feb 2012
Berichten
508
ik probeer een bukkit plugin te maken en daar heb ik gisteren een dev versie voor geupload.
nu is er een serverowner die de naam van de plugin heeft veranderd, dat kan.
dat wil ik tegengaan (die naam is toch reclame) en heb ik dit scriptje voor gebruikt, alleen zet hij de server altijd uit, ook als ik niet aan de naam heb gezeten!
Code:
if(f.getName().toString() == "MyBBReg"){
			log.log(Level.SEVERE, "You have changed the name of the plugin " + "!");
			log.log(Level.SEVERE, "The server will shutdown at each start until you have change it back!");
			getServer().shutdown();
		}
f is:
Code:
PluginDescriptionFile f = this.getDescription();
en met dit krijg je de naam zoals hij in de config staat:
Code:
f.getName()
dit scriptje wordt elke keer gebruikt als de server opstart, als hij runt kan je de jar niet aanpassen, ultimen beveiliging, als hij werkt.

hoe krijg ik dit scriptje werkend?
 
Je test precies verkeerd: Als de naam gelijk is aan "MyBBReg" dan moet juist NIET je script de server platgooien!

Test dus op ONGELIJK.
Bijv. via (vlgs. deze link en deze link)
if(f.getName().toString().compareTo("MyBBReg") <> 0{

Tijs.
 
Laatst bewerkt:
ow ja, ik was aan het testen met andere statements, had eerst ipv == != gebruikt
 
Lees even die links over vergelijking van strings. De manier van != is NIET de juiste manier.
Verder: Graag gedaan. Zet je de vraag nog even op opgelost?

Tijs.
 
het werkt!
uiteindelijk deze code:
Code:
PluginDescriptionFile f = this.getDescription();
		if(f.getName().toString().compareTo("MyBBReg") != 0) {
			log.log(Level.SEVERE, "You have changed the name of the plugin MyBBReg into " + f.getName() + "!");
			log.log(Level.SEVERE, "The server will shutdown at each start until you have change it back!");
			getServer().shutdown();
		}
 
ow haha,
nu een beetje van beide.
hij werkt zoals het hoort dus ik ga er niet meer aanzitten, maar ik ga het de volgende keer anders doen :)
 
Wat ik bedoelde is dat je in je oorspronkelijke code niet klaar zou zijn met het vervangen van == door <> of !=
Vandaar mijn nieuwe manier waarbij <> of != te pas komt.

Tijs.
 
Laatst bewerkt:
Mijn fout maar wat ik maar wil aangeven is dat jouw oude code fout was , niet alleen op het van de logica. Daarom gaf ik de links erbij.

Tijs.
 
Ik ga eraan denken en het werkt verder, hartstikke bedankt, het is helemaal opgelost! :thumb:
 
Status
Niet open voor verdere reacties.
Terug
Bovenaan Onderaan